%$*§ing IE! My new website is a no show!

Discussion in 'Web Design and Development' started by benwalker82, Dec 30, 2008.

  1. benwalker82 macrumors newbie

    Joined:
    Dec 30, 2008
    #1
    Hi,

    I've recently finished a basic website to help with my dad's business. Although simple it all works flawlessly on my mac and my iphone, but not on his PC (or any other for that matter!).

    I have tried a number of things to correct this, none of which have worked, most of which have affected the layout! Any suggestions for secret codes that MS have to have for IE to read the page, etc would be greatly appreciated!

    Thanks,

    Ben

    PS live at www.lyndhurst.eu.com
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Well, the HTML is fubar. The structure is very very incorrect. On my Mac with Firefox, nothing shows up, so it's not an IE issue, it's a coding issue. You've code like,
    HTML:
    <html>
    <head>
    <body>
    <html>
    </html>
    </body>
    </html>
    which is nonsensical. Wrong DOCTYPE, misuse of HTML tags, etc. A basic page structure needs to be as follows for frames.
    HTML:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
       "http://www.w3.org/TR/html4/frameset.dtd">
    <html>
    <head>
     <title>Page title</title>
    </head>
    <frameset rows="100, 200">
          <frame src="contents_of_frame1.html">
          <frame src="contents_of_frame2.gif">
    </frameset>
    <noframes>
          <ul>
             <li><a href="contents_of_frame1.html">Some neat contents</a>
             <li><img src="contents_of_frame2.gif" alt="A neat image">
             <li><a href="contents_of_frame3.html">Some other neat contents</a>
          </ul>
     </noframes>
    </html>
    Get things in proper HTML and we'll see how far that fixes things.
     

Share This Page