“The disk you inserted was not readable by this computer” reproducible bug

Discussion in 'Mac Basics and Help' started by dfelix, Mar 15, 2018.

  1. dfelix macrumors member

    dfelix

    Joined:
    Jul 13, 2011
    #1
    Hi,

    So I have a lot of hard drives. As the macs have problems having these internally, I have keep them externally.

    I have 5 different USB docks, of different makes and models. 3 of them are a bit older (C, D, E), the other 2 (A, B) just purchased last week.

    The hard drives I have are of several different sizes.

    Here is the problem: Whenever I insert one of the hard drives formatted in any of the 3 older docks into any of the newer docks, I get a “The disk you inserted was not readable by this computer” error. If I insert it into the older docks, it works without a hitch.

    When I insert one of the drives formatted by the newer docks into any of the older docks, I get another “The disk you inserted was not readable by this computer”. If I insert a drive formatted in new dock A into new dock B, it still works properly.

    If I insert a drive formatted in any old dock (Say, docks C, D, E) into any other old dock which was not used to format it, I get another “The disk you inserted was not readable by this computer” error.

    This happens on any drive I have which is 3TB or larger. All other drives <= 2TB work properly in all docks.

    Brands are either WD Green or HGST.

    The old docks are two different Plugable models, and an Anker model. The new ones are a Cable Matters model and an Orico transparent one.

    Does anyone have any experience with this?
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    I'll -guess- that the older docks may have some kind of internal chip/circuitry that doesn't recognize drive sizes larger than 2tb in size.

    Possible solution/workaround:
    - Label docks and drives and be careful about which ones you use (because of the limitations)
    - Replace the old docks with newer ones.
     
  3. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #3
    Agreed. Most likely the USB chipset/firmware version of the dock...nothing to do with the drives.

    The other variable—that you cannot change—is that sometimes Apple changes a USB/TB chipset brand/model/firmware version and that can be enough for a dock to stop working (reliably).

    I have two older docks that are great on all older Macs, and all drives ever used (HD, SSD) but on several newish Macs with USB 3 they will mount, and then randomly unmount. Unreliable to the point of unusable.

    In my case, one dock has USB 3 and FireWire 800. The USB 3 works fine on USB 2 Macs. On USB 3 Macs, I use FireWire800 with a Thunderbolt adapter. Rock solid. Proves the problem is the USB bus communication or compatibility (either the dock and/or the Mac).

    Might be time to retire a few older, less compliant docks and streamline the workflow.
     
  4. dfelix thread starter macrumors member

    dfelix

    Joined:
    Jul 13, 2011
    #4
    Thank you for the responses guys.

    I guess that is the thing to do. But it still mystifies me as to why this happens.

    So just for funzies, let's analyze this a bit deeper. Someone is bound to encounter the same problems I have.

    So I have an empty 3TB drive lying around. I have formatted this in one of the old plugables. The other plugable I have does not want to see the 3TB drives anymore, but it would connect a 256GB SSD to the Xbox solidly. So I guess that one will be reassigned to the Xbox, but the other ones apparently as well as I have no other use for any of them at the moment.

    I format it and it shows:

    [​IMG]

    Yet when I take it out and put in in the new Cable Matters dock:

    [​IMG]
    [​IMG]


    It shows up as an unreadable MBR drive, but it's obviously formatted as GPT.


    Now I format it as APFS in the new Cable Matters dock:


    [​IMG]

    And it shows up correctly. I then proceed to try it in the old plugable dock A:
    [​IMG]
    [​IMG]

    So, drives formatted as GPT show up as MBR in the opposite dock. This is puzzling.
    --- Post Merged, Mar 30, 2018 ---
    Searching for these errors, the 375.07GB file zise (should be 3TB) and the 0xEE that diskutil list shows, only shows up these two threads (by the same guy) on the entire internet

    https://discussions.apple.com/thread/7327280
    https://discussions.apple.com/thread/7324876

    Similar problem though. 3TB drives in size. Mac OS Extended instead of APFS. This has been around since 2015. Apparently those Seagate's had inherent docks, and were connected through Thunderbolt instead of USB. What could possibly cause this?
    --- Post Merged, Mar 30, 2018 ---
    The one thing I have been able to find which could be relevant is my Mac is a mini from 2012. That dude's 27" imac is also from 2012. Which goes into what Hobowankenobi posted

    So was this something that only affected my generation? Will this finally force me to upgrade to like a 2013 Mac Pro (as I do not have the dough yet for an iMac Pro, even though it's the one I would most benefit from because of my upgrade schedule. But still, nMP with 128GB ram would do wonders to my workflow)
     
  5. Forum-User macrumors newbie

    Joined:
    Jul 8, 2009
    #5
    I believe your drive dock firmware capabilities are causing your disk reading issues.

    Years back, I experienced a similar issue when using disks larger than 2 TB in USB external drive enclosures. I had a 2 TB drive that worked fine in enclosure A, but a 3 TB drive in enclosure A couldn't reliably format or read disk partitions properly. When I put the 3 TB drive in enclosure B (which was the identical model as enclosure A, but came with newer firmware), it worked perfectly. I contacted the manufacturer, and they sent me a replacement controller card for enclosure A, which could then properly handle disks larger than 2 TB.
     

Share This Page

4 March 15, 2018