TV 4K with tvOS 13 (beta) - Steam Link with PS4 Dualshocks

originalmagneto

macrumors member
Original poster
Jun 7, 2015
78
65
Slovakia
1. tvOS 13 developer beta runs surprisingly good on my TV 4K (HBOGO,Plex,Netflix,Amazon Prime, steam link all work)

2. Tried connecting the PS4 dualshock and it works great.

3. Tried Steam link with dual shock = works great

4. Tried connecting two DualShocks to my TV and they connect

5. Two dualshocks + steamlink 2 player game (cuphead) - does not work, the game recognizes 2 players and the 2 controllers work, but it’s laggy and somehow the controls keep interfering with each other. Don’t know where the problem is but I sure hope it gets resolved.

The main takeaway is that the TV 4K has become a full fledged gaming platform after 2 years and it will get better. With the addition of Xbox and PS4 controllers + steamlink support, it’s poised to take over game streaming and arcade home gaming.

If the bugs (problems with 2 controllers and steamlink) get sorted out, we have a WINNER.

One of my other issues is, that the dualshocks will get unpaired with PS4 after they are paired with the TV and I had to connect them by cable to the PS4 when I wanted to use them.
 

FarmerBob

macrumors regular
Aug 15, 2004
134
37
1. tvOS 13 developer beta runs surprisingly good on my TV 4K (HBOGO,Plex,Netflix,Amazon Prime, steam link all work) . . .
Not mine. With the Black remote the "Select" button doesn't function as it once did. In some apps it no longer acts as "Pause/Play". Actions from the remote are slow to act. The whole unit is slow to act. When first turned on I get that "Highly Blurred" whitish screen instead of the "Home" page. I was binging Season 3 of Colony and at the end you can not select the next episode to play it. As the credits play in an upper corner block the "Screensaver" kicks in and when you back out of that the previous episode starts playing in the upper credits block. Or just turns itself off . . . rinse, repeat . . .

I have restarted several times hoping to "set" things and no luck. It was a pain. Since it was so hard to get around I didn't go far. But that's it for me so far . . .
 

Max E Verde

macrumors regular
Jan 12, 2005
207
30
New Jersey
I tried connecting my DualShock 4 to Public Beta 1 and Steam Link wants to configure my DualShock 4, when I press the final button to configure the app closes, and upon restarting when I press X it acts like I'm pressing O and closes the app. And the Siri remote no longer works in the app so I tried 3 more times by reinstalling the app to the same results.
 

Ocellaris

macrumors newbie
Jul 22, 2013
23
27
I tried connecting my DualShock 4 to Public Beta 1 and Steam Link wants to configure my DualShock 4, when I press the final button to configure the app closes, and upon restarting when I press X it acts like I'm pressing O and closes the app. And the Siri remote no longer works in the app so I tried 3 more times by reinstalling the app to the same results.
This is exactly where I am stuck as well. I can’t get past configuring the controller since pressing O closes the controller configuration.