10.14.2 - Does sleep work?

Discussion in 'macOS Mojave (10.14)' started by Howard2k, Dec 8, 2018.

  1. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
  2. whoisyourdaddy macrumors regular

    Joined:
    Oct 2, 2018
    #3
    Yes/No
     
  3. n-evo macrumors 65816

    n-evo

    Joined:
    Aug 9, 2013
    Location:
    Amsterdam
    #4
    Nope.

    MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports) here.
     
  4. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #5
    No sleep doesn’t work? Or no you’re not losing 20%-30% overnight?
     
  5. itegypt macrumors 6502a

    itegypt

    Joined:
    Aug 6, 2011
    Location:
    FL
    #6
    sleep work fine and I just checked for you I'm losing less than 10%

     
  6. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #7
    Thanks
     
  7. wegface macrumors member

    wegface

    Joined:
    Jul 15, 2018
    Location:
    Portugal
    #8
    Had this issue with the early versions. Since 10.14.2 still 100% after 8 hours sleep. Across a few machines. Problem resolved.
     
  8. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #9
    Thanks!
     
  9. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #10
    Lost 17% last night. Still atrocious compared to Sierra, but a slight improvement.
     
  10. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #11
    Only 4% last night. Looks like it might be fixed after all.
     
  11. F23 macrumors newbie

    F23

    Joined:
    Jan 4, 2014
    #12
    Yes. Even more.
     
  12. AppleMythos macrumors member

    AppleMythos

    Joined:
    Aug 7, 2017
    Location:
    San Francisco
    #13
    i lose no more than five percent over extended periods of time on sleep, same as before.
     
  13. MacGizmo macrumors 65816

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #14
    I lose about 2-4% max. Maybe try turning off App Nap in the prefs to see if that changes things for you.
     
  14. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #15
    Back to 14% lost. Looks like it's slightly improved over 10.14.0, but not significantly or with any regularity.
     
  15. wegface, Dec 20, 2018
    Last edited: Dec 20, 2018

    wegface macrumors member

    wegface

    Joined:
    Jul 15, 2018
    Location:
    Portugal
    #16
    On Battery power- In terminal run the following (this only displays current settings):
    pmset -g

    What is the output of the command?
     
  16. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #17
    Code:
    System-wide power settings:
    
    Currently in use:
    
     lidwake              1
    
     autopoweroff         1
    
     standbydelayhigh     86400
    
     autopoweroffdelay    28800
    
     proximitywake        0
    
     standby              1
    
     standbydelaylow      10800
    
     ttyskeepawake        1
    
     hibernatemode        3
    
     powernap             0
    
     gpuswitch            2
    
     hibernatefile        /var/vm/sleepimage
    
     highstandbythreshold 50
    
     displaysleep         5
    
     sleep                5 (sleep prevented by fud, coreaudiod, iTunes)
    
     acwake               0
    
     halfdim              1
    
     tcpkeepalive         1
    
     disksleep            10
    
    
     
  17. Matmania macrumors newbie

    Matmania

    Joined:
    Nov 27, 2018
    #18
    Yes but battery shot.
    Just replaced so lets see how it goes.
     
  18. Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #19
    Yes, sleep works (on MBA for reference), and no I'm not losing sleep (except when i'm up posting on MR) :D

    I did have to do SMC reset, but that wasan't the reason. unrelated
     
  19. wegface macrumors member

    wegface

    Joined:
    Jul 15, 2018
    Location:
    Portugal
    #20
    Your standbydelayhigh is set to 24 hours. *If* you ran the command while on battery power, this explains why you lose so much overnight- the machine is never going to full sleep.
    sudo pmset -b standbydelay SECONDS
    (change seconds to something more fitting.) I set mine to half an hour.
    All settings while on AC power will remain the same.
     
  20. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #21

    Thanks. I did originally run the commend with power connected, then re-ran it with the power unconnected (which is what I posted).

    I just tried again to ensure that I'm not insane.

    In both cases (power connected vs on battery) there were changes to some of the settings but the standbydelayhigh remained unchanged at 86400.

    I've set this for 30 minutes. Thanks for your help, I'll try it again over the next few weeks and see how it performs.

    I don't need to be concerned about the AC Power message right?


    Screen Shot 2018-12-21 at 9.18.31 AM.png


    Current pmsettting on battery and on power.

    Battery:
    Screen Shot 2018-12-21 at 9.21.01 AM.png





    Power:

    Screen Shot 2018-12-21 at 9.21.46 AM.png
     
  21. wegface macrumors member

    wegface

    Joined:
    Jul 15, 2018
    Location:
    Portugal
  22. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #23
  23. Howard2k thread starter macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #24

    Hey, just wanted to say thanks again. From the afternoon of Dec 24th until the afternoon of Dec 26th, I lost 20%. I was using it during that time, so it looks like the sleep function is working properly again.
     

Share This Page