10.15.2 Broke Camera Tethering

sperdynamite

macrumors member
Original poster
Sep 21, 2011
41
12
I personally use Lumix Sync for my Panasonic camera, but 10.15.2 killed tethering in Lightroom and Capture One as well. Apparently Capture One has issued a fix but I am still out in the wilderness as Panasonic is a little less responsive.

Is there any way to make Apple aware of this? Anyone know if a fix is coming?
 

Fishrrman

macrumors Core
Feb 20, 2009
19,449
6,746
The way I see it, you have 2 options in front of you:
1. Keep using 10.15.2 until 10.15.3 is "officially released". But then you can't tether.
2. Sign up for the developer program and try the 10.15.3 beta. I seem to recall reading that this corrects the problem for some users.

BUT... BEFORE you attempt this... use either CarbonCopyCloner or SuperDuper to create a bootable clone of your 10.15.2 install on an EXTERNAL drive.
If you do not do this, and run into problems with the beta, it could be VERY difficult to get back to the public release of 10.15.2.
(having the cloned backup will make it almost like child's play)
 
Last edited:

gilby101

macrumors 6502
Mar 17, 2010
314
125
Tasmania
Sign up for the developer program and try the 10.15.3 beta. I seem to recall reading that this corrects the problem for some users.
10.15.3 beta fixed tethering for me using a Canon and their EOS Utility. I assume it fixes it for all with the tethering issue introduced with 10.15.2.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.