10.3.6 - Spinning wheel on all Apple apps except iTunes...

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Schdog, Dec 4, 2004.

  1. Schdog macrumors newbie

    Dec 4, 2004
    Hi all,

    The last few days I've developed some serious problems with my DP1.8 G5 / 10.3.6 and I don't know what to do next. Within seconds of firing up any Apple software (Safari, Mail, Textedit, iCal, Calculator, Disk Utility, in fact anything except iTunes - so far) the application goes into spinning wheel mode and the only way out is to force quit. No third-party applications are affected. Safari is the most curious, it will start to load a site, but then hangs right before rendering the first page ("3 of 4 items" etc).

    The only hardware recently added was an LCD screen a few weeks ago. No issues there I think. No new significant (to my knowledge anyway) software has been installed recently, certainly none right before the problems started appearing.

    I'm unable to repair permissions using Disk Utility as it doesn't get beyond this "half-loading" stage, and if I use the terminal to try to repair permissions I get as far as the password prompt and then can't enter anything.

    And here's a really annoying thing: If I try to download any third-party diagnostic apps, I can't run them, because Installer doesn't run anymore either!

    So I have reached the point I figure something is seriously wrong with the core OS, and I have to do a full reinstall. But here's the final injustice: we moved house a few months ago, and I can't find the installer disk anymore!

    Before I have to shell out for a whole new copy of Panther (or start drinking, a lot), does someone maybe have an idea what the actual problem might be, and whether there is in fact a simpler solution?

    Many thanks
  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    I would say to check the catalog/file system using Disk First Aid, but you say you cannot find the CD/DVD.

    Try booting in single user mode (command-s) running fsck (follow instructions on screen) then type 'reboot'.

    If something is caught, run fsck again (and again) until all errors are fixed or the OS won't fix them.
  3. Schdog thread starter macrumors newbie

    Dec 4, 2004
    Thanks for the quick reply, Sun Baked.

    I followed your advice, and fsck reported that the system was OK.

    So back to square one... :\
  4. Peter9 macrumors member

    Jun 26, 2004
    I'm pretty sure the installer disk for Panther has an option to reinstall only Panther's Apps. I'd just do that
  5. Schdog thread starter macrumors newbie

    Dec 4, 2004
    Well, that was my first thought too. and then I couldn't find the installer disk, as I mentioned above. Bit of a problem really.
  6. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    Maybe your caches are corrupt? Try deleting everything inside the /Library/Caches and ~/Library/Caches folders - see if that makes things better. You will need to at least log out and back in or restart for the change to take effect.
  7. Schdog thread starter macrumors newbie

    Dec 4, 2004
    Wrldwzrd, you are the wizard of wizards, I tried what you suggested and it seems to have worked, everything appears to be back to normal again.

    Thanks very much, I owe you one big time!
  8. Chip NoVaMac macrumors G3

    Chip NoVaMac

    Dec 25, 2003
    Northern Virginia
    Many thanks! I too had the spinning wheel issue. I used OnyX (http://www.boostware.com/os/mac/onyx.html) to do the dirty work.
  9. iGary Guest


    May 26, 2004
    Randy's House
    1. Repair permissions.
    2. Restart.
    3. Go to terminal.
    4. Type in sudo periodic daily
    5. Wait for that to finish
    6. Type in sudo periodic weekly (this one takes a minute or two)
    7. Type in sudo periodic monthly
    8. Wait for that to finish.
    9. Type in sudo update_prebinding -root / -force
    10. Wait for that to finish.
    11. Restart.
    12. Insert original install disc that came with computer.
    13. Restart with boot to that CD.
    14. Open disk utility.
    15. Click on First Aid.
    16. Perform "Repair Disk"
    17. Hopefully you get "Volume appears to be OK," if not repeat until it does.
    18. Restart.
    19. Repair permissions again.
    20. Restart.

    Let us know how it works.

Share This Page