10.3.7 crashes Myst 4?

Discussion in 'Games' started by hoyboy9, Dec 19, 2004.

  1. hoyboy9 macrumors member

    Oct 1, 2004
    After updating to 10.3.7, Myst 4 crashes every time I attempt to change the screen resolution, and also randomly during the game. It never crashed under 10.3.6. The game was patched to 1.01 before I updated to 10.3.7.

    Anybody else have this problem? I would reinstall it, but I left the install CD back at college. Just wondering if there is some sort of easy fix.

    Here are my specs: PB G4 1.5, 512 MB RAM, ATI Radeon 64MB.
  2. illustratorDavi macrumors 6502

    Jun 7, 2004
    North Yorkshire
    Oh GREAT !!!!

    First Myst 3 Exile doesn't really like mac os X, now 5 weeks after buying Myst 4 - its having problems with 10.3.7

    Unfortunately I had to uninstall my copy of myst to free up some space to do some design work -- so I don't know if its working on my machine yet- sorry

    I'll get it reinstalled in a couple of days and see if it works and get back to the forum with the result.

    Maybe a quick email to Ubisoft might give you an answer. While you telling them ask if it works with Tiger ? - I think we will be in for a disappointment. :(

  3. Cougarcat macrumors 604

    Sep 19, 2003
  4. kentd macrumors newbie

    Jun 5, 2003
    Boston, MA
    I just got Myst 4 (after updating to 10.3.7), and I cannot get it to work. It always crashes when I press ESC during play (to save or load a game). Happens on my pbook g4 1GHz and on a Dual G5 2.0GHz. Both are running 10.3.7. I did the Myst 4 update to 1.0.1 on the G5 and it made no difference.

    I'm hoping a new patch will come out soon.
  5. radioheadmb21 macrumors newbie

    Dec 27, 2004

    Alright, I've got a PowerBook G4, 10.3.7, i had a little trouble installing it, but once installed I couldn't leave the 'options' menu without it crashing. What's up with this? It seems a lot of people are having the same problem?
  6. Mechcozmo macrumors 603


    Jul 17, 2004
    Have you repaired permissions? Funky behavior is often due to messed up permissions...
  7. virux macrumors newbie

    Dec 28, 2004
    Nothing BUT trouble

    I bought Myst IV 2 or 3 days ago, and I've had nothing but trouble. For one their using a buggy Windoze ported Java installer (which is a no no for this type of thing), and Myst keeps quitting randomly during play and after exiting menus. Showing exactly the same type of problems you guys are having. I think I'm gonna have to boot in 10.2 for this.

    Edit: BTW I repaired permissions, doesn't make a difference. And whats this with a 2 or 3 second wait when moving from spot to spot on G3s?
  8. Eric5h5 macrumors 68020

    Dec 9, 2004
    I would like to try that, but it seems to be a Java thing that wants to open with Jar Launcher. Except no such program appears on my system. Evidently it's supposed to be part of OS X, but I don't have it. All I've done to my system is update from 10.3.5 to 10.3.7. So where is Jar Launcher supposed to be, can I get it somewhere (I did try searching the Apple site), or is there some other way of running the Myst 4 update?

    Myst 4 does seem to run with 10.3.7 for me, more or less, though I haven't played it extensively yet (I would like to update it first....). The mouse pointer from the desktop was permanently stuck in the upper left corner of the screen at first, which is pretty annoying, but changing the resolution from 800x600 to 1024x768 fixed that for some reason. Changing game settings does crash the game within 10-15 seconds, but quitting before the crash at least saves the settings. Since I don't mess with them once I have them set the way I want, I guess I can live with that, and I don't seem to have problems loading and saving.

    Yes, the lousy installer is annoying, and the unusable (for me) updater is even more annoying. A shame, since the game itself seems really nice.

  9. daveybe macrumors newbie

    Oct 31, 2004
    •Ubi's support website posted a response to this issue on 12/27:

    I upgraded to OS 10.3.7 and know the game crashes whenever I load my saves.

    A number of customers have mentioned that they have solved this crash by moving their game folder from the applications file to the desktop. This is currently the only solution to this issue other than rolling back to the previous Mac OS..

    Seems too simple to be true, but they claim it helps.

    •btw, anybody get Myst4 to run on an iBook with Radeon Mobility 7500? I've heard enough bad reports about Myst4 and Mobility chips that i'm afraid to buy the game. I've tried the ares_config.xml hack with the demo and had no luck. Is there any hope of better results with the game itself?
  10. sethwerkheiser macrumors regular

    Jan 22, 2003
    Brooklyn, NY
    Myst 4 on my iBook

    My wife has played Myst 4 on MY iBook.... G4, 256MB RAM... it plays decent for her. It won't play on HER iBook though... G3, 640MB RAM.... though believe me, I tried ;)
  11. Eric5h5 macrumors 68020

    Dec 9, 2004
    OK, seems the problem was the Java update I'd been putting off (26Mb is kind of a lot on dial-up). Now the updater works...the game still does the crash-after-changing-options thing, but the gameplay itself still seems OK. If it's any consolation to anyone, even my dual 2.5GHz G5 experiences a delay of a second or so between locations. Either it's not optimized all that well, or there's just a lot of data to load and process.

  12. virux macrumors newbie

    Dec 28, 2004
    But, Myst III was in 360, and had pretty much the same amount of data to load, so why should it need an extra few seconds on a G5? And I was running Myst III on an 400mhz G3 iMac! The fact is, Ubisoft developers have done a bodge job, only by using Java though.

    One thing I did which helped Myst IV was take it out of the Ubisoft folder and put it in Applications, maybe Myst IV doesn't like it being nested to far into directories. I'm gonna try putting in on my HD, so in the root directory. See if that helps. We might have to wait for 10.3.8 or Tiger.
  13. flappo macrumors regular

    Jan 8, 2003
    in the cubicles
    i wouldn't mind , but the games utter rubbish

    get rtcw , thats more like it !

  14. Eric5h5 macrumors 68020

    Dec 9, 2004
    I have RTCW, and it's fun, but it's not Myst, and it's not even an adventure game, now is it? Myst 4 is really very good indeed; the porting is not so great however. I suppose we should be glad that it's one of those quite rare Mac/PC simultaneous releases, but Blizzard does a better job of that.

  15. virux macrumors newbie

    Dec 28, 2004
    I believe its a memory management problem, and the fact that they're using their own user default controller. Apple didn't supply developers with NSUserDefaults for nothing.

    And even in the cut scenes, the game is slow. If my mac can display a full size DVD without stutter, I'm sure Myst 4 could.
  16. iamacat macrumors newbie

    Jan 19, 2005
    You just have to sneak up on it

    Myst IV used to crash on me during game, after saving or after I tried to change graphics options. Then I changed display mode from 640x480 to 800x600, turned on all their extra graphics effects and exited quickly before it had a chance to bomb. After that it saved my preferences and everything worked like a charm since then.

    The crash is in "ATIRadeon8500GLDriver", which is mentioned in 10.3.7 update description for some minor bug fixes. Given the quality of their Mac port, I would guess the bug is in the game, not driver. Fiddling with graphics settings should somehow bypass it.
  17. gopher macrumors 65816

    Mar 31, 2002
    Maryland, USA
    Can the ATIRadeon8500GLDriver be removed to allow the game to work? I found it would crash in 10.3.7 on my Powerbook even though it has a Radeon 9700. I had to downgrade to 10.3.6 to get the game to allow me to save files without crashing.
  18. studio309 macrumors newbie

    Feb 28, 2005
    :mad: Man this is aggravating. What is up with this game? I'm trying to run this game on a G4 (Quicksilver) 800, with a Radeon 7500 card and OS 10.3.6. The OS is a new install on a separate drive just for MYST 4. The game continues to quit when I save or change options. And, the graphics are screwed up, but it seems to happen only in dark settings. I get odd shaped blocks of black or color that follow the camera and change shape as I move through the scene. It gets to the point where I can't see the scene and have to quit.
    Screen Shot 1
    Screen Shot 2
    This is after changing the screen resolution from 640 x 480 to 800 x 600
    Screen Shot 3

    I've reinstalled and updated the game, before and after reinstalling the OS -- tried moving the game folder to the desktop -- tried updating the ATI drivers... $40 is a lot for a game this buggy. I know, UBI blames Apple for constantly improving their OS. Go figure.
  19. gopher macrumors 65816

    Mar 31, 2002
    Maryland, USA
    Assuming you are using the 1.0.1 update of Myst IV, I would presume that your graphics card has something not right about it.
  20. jared_kipe macrumors 68030


    Dec 8, 2003
    Certainly is odd, Myst 4 plays very well on my G5 with a 5200 in it.
  21. studio309 macrumors newbie

    Feb 28, 2005
    I did install the update. I would suspect that it was a problem with the card too, except that MYST IV is the only software that displays any sort of graphics anomaly. MYST III Exile runs beautifully, as does Riven, Warcraft, Starcraft, (Photoshop, Illustrator, Carrara 3D Studio, Bryce, Cinema 4D....) etc. The card is the stock ATI 7500 that came with the G4.
  22. billrc macrumors newbie

    Mar 18, 2005
    Cannot play myst 3 or 4

    Hi, bought a new G5 2.5 OSX 3.7 - salesman sold me myst 4 with 3 included. Have email support and called three times with not result. Game is on my computer but when I try to play either game the screen goes black and stays that way for Myst 4 and Myst 3 just crashes. At least you guys can get somewhere with the game. This is a total bust for me. I downloaded the patch 1.1 to 1.03 and when I try and to use it I get a message that the software is not on my hard drive. Are they talking about the Myst software?
    Any suggestions would be much appreciated.

  23. gopher macrumors 65816

    Mar 31, 2002
    Maryland, USA
    Yes. Myst IV does not work with 10.3.7. It does however work with 10.3.8. Use the following tips to upgrade to 10.3.8:


Share This Page