10.3 refuses to reinstall on g3 that ran 10.3 before

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by tomato, Sep 22, 2004.

  1. tomato macrumors newbie

    Jan 3, 2002

    I have a g3, updated smoothly from 8.6 to 9.0 to 9.2 to 10.3, but classic was nuked, so I erased and partitioned (to create a seperate classic partition) but 10.3 now refuses to install either on the blank partition or over the classic install - saying there is no previous version of X to install over...

    Can you help?

    Here is the story

    I aquired a g3/ 350 (with scsi 8gig and 128MB ram) running os 8.6.

    Upgraded it to 9.0 with the os9.0 apple CD, boosted the memory to 512MB, and attached a 30gig 7200rpm ata HD.

    Using the online updates, I updated it to os9.2 (i can't remember if it was to 9.2.1 or 9.2.2). All went smoothly.

    I then got the 3 CD set for 10.3 so i did the upgrade on the SCSI HD, which went completely smoothly. It wiped out 9.2 but according to apple (!), classic was part of osX so i wasn’t worried.

    Discovered that wasn't true. Discovered I couldn't install Classic with my 9.0 CD.

    Okie, so i decided to partition my HD, and have a separate os9 partition. Reformatted the SCSI HD wiped out os X, partitioned it with the apple tool on the 10.3 CDs.

    10.3 refuses to install!!! It says " You cannot install Mac OS X on this volume. An earlier version of Mac OS X is not installed" for all drives.

    Eh? So how come it worked last time, when I was upgrading from 9.2??

    I needed to get on with work, so I erased the SCSI HD (again!), and reinstalled 9.0 from the Apple CD.

    But now the online updates refused to install properly - various files don't install etc - e.g. help.in and it all went so flakey I had to reinstall 9.0 again from scratch.

    And now 10.3 refuses to install over the 9.0 partition. (on the SCSI HD) (giving the same error message as given above.)

    I have no idea what's happened, and I'm stuck at os 9.0 with a set of os 10.3 CDs that I can't use :(

    Any ideas?


  2. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    Take out the RAM until it hits the original 128MB. Then you'll have no problem installing Panther, I bet.
  3. tomato thread starter macrumors newbie

    Jan 3, 2002
    just tried it, didnt work

    Couldn't see how that would work, but tried it any way.

    Pulled out all the extra ram, till there was just the 128MB stick that came with the g3, in the same location. 10.3 still refuses to install.

    I'm actually worse off than before I tried to install X as now i can't use some apps that require 9.2.2 (like MSN messenger).

    One thing that occured to me - the SCSI HD is now in macOS Extended Format, wheras i think before, i think it was in macOS Standard Format. I'm not sure if that has anything to do with it.

    I just looked at the disktools utility on the 9.0 CD, and it also has the ability to format in macOS Extended, so it's not a X-only thing.

    Still looking for help :(

  4. j33pd0g macrumors 6502

    Mar 20, 2003
    Central NY
  5. tomato thread starter macrumors newbie

    Jan 3, 2002
    nowt wrong with the hard drive

    nowt wrong with the hard drive, it's running os9.0 perfectly well and I used it to post these messages. Diskcheck says it's all working fine.

  6. tomf87 macrumors 65816


    Sep 10, 2003
    For some reason, I'm think you may have had a X System folder on the disk so that's why the upgrade went fine the first time.

    The disks I received with my iMac in 2001 were upgrade only disks. However, on all of the shelves at the Apple Stores were retail, full installation disks. Do your disks say upgrade on them?
  7. nesuser2 macrumors 6502


    May 15, 2004
    NW Ohio
    I'm not an expert but there was some sort of design that OS X wouldn't install on hd's larger than 6gb if the processor was 350 and under. My numbers could be mixed and this could be far from a solution but maybe you could peal into it and find an answer? Best of luck...
  8. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC

Share This Page