10.6.2: iChat sounds come out of internal speaker regardless of sound settings

Discussion in 'macOS' started by TheSpaz, Nov 10, 2009.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    Just like the title says.

    After updating to 10.6.2 on my Mac Pro, iChat sounds ONLY come out my internal speaker. All other sounds come through line-out with no problems. I also checked my iChat preferences and made sure I had "Line Out" selected in Audio/Video.

    I've restarted a few times and changed System Sound settings and I cannot get my iChat sounds to come out of my line out (external speakers). Like I said, all other apps and sounds are coming out line out like before.

    I think it must be an iChat specific problem. I even tried trashing the iChat preference file and that didn't work.

    Does anyone have a fix for this? It's driving me up the wall. I never had a problem before 10.6.2.
     
  2. southerndoc macrumors 65816

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
    #2
    In the sound preferences of system preferences, under sound effects, where does it say "play sound effects through?" If it says internal speakers, then it will always play through there even if your output is selected as line out or USB speakers.
     
  3. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
  4. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #4
    I searched around and I couldn't find my specific iChat issue. All other sounds are working fine for me except for iChat.

    Sorry I wasted your time. Geeze.

    By the way... I saw those threads but it didn't say anything about iChat. The only useful response I've found so far is the reply just above yours. Thank you Southerndoc! I'll have to try that when I get home. I didn't realize there was a separate setting for which speaker set to play sound effects through. I guess iChat sounds can be called Sound Effects but I didn't realize iChat sounds were affected by the Sound Effects preference pane. Again, thank you for your helpful reply.

    Jessica on the other hand wasn't the least bit helpful at all.
     
  5. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #5
    Thank you! That makes an incredible amount of sense now. I always have alert sounds turned off so that would be why I didn't notice if ALL sound effects were coming out my internal speakers. Also, 10.6.2 changed all of my sound settings for some reason, while I fixed Sound In and Sound Out, I didn't check my Sound Effects settings.

    Thank you, thank you, thank you!

    I hope someone else will be able to stumble upon this thread and make use of this tip as well.

    Before this thread existed, there was no solution to my problem. Jessica's reply didn't tell me anything useful.... except for giving me links to stuff I already looked at with no answers or reason why my iChat sound effects were screwed up.
     
  6. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #6
    Just wanted to confirm what southerndoc had said.

    iChat's sounds are tied to the "sound effects" option in Sound Preferences. I just tested this.

    Make sure that is not set to Internal Speaker.

    -Kevin

    Edit: Ooops...looks like you already figured it out.
     

    Attached Files:

  7. southerndoc macrumors 65816

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
    #7
    Glad I could help. I stumbled on the setting a while ago. I actually send iChat sounds to the internal speakers and regular sound to my Bose USB speakers. When listening to iTunes, I could barely hear the notification sounds of iChat. Now I send them to the internal speakers with the volume cranked up. Sometimes the volume settings get reset though. Guess it's just a bug.

    Some people spend more time searching for various threads and cut-and-pasting the links to those threads instead of simply answering the question. With a busy board like MacRumors, there are bound to be repeated threads.
     
  8. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #8
    The thing is... those other threads that she gave me didn't deal with my problem. I already checked my sound preferences, but I didn't realize that iChat sounds were considered "Sound Effects" by the system... I also didn't realize that you could route sound effects to internal speakers by themselves... I turned off System Sounds a long time ago and haven't had to go back ever since.
     

Share This Page