Resolved 1080 TI's & GT120 in Win10 = Big Headache!

Dr. Stealth

macrumors 6502a
Original poster
Sep 14, 2004
812
722
SoCal-Surf City USA
Hello all,

I just upgraded the GPUs in my 2010 5,1 cMP from dual GTX-680’s to dual GTX-1080 TI’s. My 680’s were flashed with mac roms so I had boot screens. I figured I’d just use a GT120 for boot screens if needed in my new build.

Everything works flawlessly in macOS with the three cards installed, two 1080’s and the GT120. In Windows 10 not so good. I’d like to keep all three cards installed for easy access to boot screens if needed. Windows works perfectly with just the two 1080’s, windows also works fine with just the GT120, but if I try to boot to windows with all three cards the 1080 and GT120 drivers conflict and I get black screens on boot. I’ve tried MS drivers, Apple drivers and direct from Nvidia for the GT120. All have issues conflicting with the 1080’s.

So I guess I have a couple questions.

1. Has anyone been able to get a GT120 to live harmoniously along side 1080’s in Win 10?

2. Is there another slot-powered GPU that may be a better choice, more compatible, than the GT120?

3. Any other ideas besides leaving the 120 in a drawer until needed?

I’d really like for win 10 to completely ignore the 120 but even with nothing plugged into it windows has major issues with it.


Thanks in advance for any ideas !
 

FrancoisC

macrumors 6502a
Jan 27, 2009
524
265
Montreal, Qc
You say you tried Apple/MS/Nvidia's drivers, but in the end, they all come/are made by NVIDIA. I think the GT120 is not supported by nvidia anymore, hence the possible driver conflict.

Did you try de-activating it (the GT120) in Windows device manager? It's not guaranteed, but it might fix your issue, since hopefully windows won't load it's drivers this way.

PS: I just checked on nvidia's site, the latest available drivers for the GT120 in windows predate the 1080 release, so you have drivers that work with the 120 but not the 1080 and vice versa, I'm almost certain that this is what cause the issue, but the device manager trick should do the job.
 
  • Like
Reactions: itdk92

flowrider

macrumors 603
Nov 23, 2012
6,255
2,384
Only thing I can suggest is to get the TI's flashed by MVC. Doing that would give you the boot screen and, AFAIK, would also give you 5GT/s link speed in Windoz.

Lou
 
Jul 4, 2015
4,488
2,549
Paris
Because Nvidia cut off support for such old cards. When Windows or GeForce Experience detects the two cards it will load either the very old driver without Pascal support or the new drivers without pre-Fermi support.

Yes you can disable the GT120 in Device Manager. Alternatively remove the card and use start up disk preferences to choose OS.
 

Dr. Stealth

macrumors 6502a
Original poster
Sep 14, 2004
812
722
SoCal-Surf City USA
@FranciosC
Yes, I've tried disabling the 120 in device manager but on next boot the problem is back. I've also used the gpedit routine to try to stop windows from installing any drivers for the 120 but windows still attempts to install the drivers on the next boot.

@flowrider
Yes, I thought about going the MVC route and have him flash one of my cards. However at this time he only flashes Reference or Founder edition 1080 TI's. My cards are EVGA 1080 TI FTW3's. Plus $225.00 to flash a rom is absurd.
 

BillyBobBongo

macrumors 68030
Jun 21, 2007
2,520
1,100
On The Interweb Thingy!
Alternatively remove the card and use start up disk preferences to choose OS.
This is the best answer.

I had a GT 120 in my system alongside a GTX 1060, the GT 120 was always selected by Windows as default. Save yourself the time and headaches and just pull the GT 120 and put it in a drawer. For the few times that you may need to see a boot screen...just put it back in.
 

flowrider

macrumors 603
Nov 23, 2012
6,255
2,384
@flowrider
Yes, I thought about going the MVC route and have him flash one of my cards. However at this time he only flashes Reference or Founder edition 1080 TI's. My cards are EVGA 1080 TI FTW3's. Plus $225.00 to flash a rom is absurd.
You could message him, and ask if he will flash your card. My GTX 1080 is a Gigabyte G1, 3 fan OC card, not a reference card, and he flashed it for me.

Lou
 

Asgorath

macrumors 68000
Mar 30, 2012
1,573
479
The main thing would be to keep the GT 120 card around in case you run into problems on the macOS side, but yeah, it's probably best to just remove it from the system by default.
 

Dr. Stealth

macrumors 6502a
Original poster
Sep 14, 2004
812
722
SoCal-Surf City USA
Persistence pays off !!! It's all working now. After banging my head on my desk for a week swearing at Windows I finally got everything working together and can button up my machine.

This was the solution: When windows initially see's the GT120 card it identifies it as a VGA Compatible Video Controller. At this point everything is okay. But within seconds of booting to the desktop it attempts to install drivers for it and that's what brings down all three cards. I was finally able to get windows to STOP installing drivers automatically. The card stays as a basic VGA Video Controller with no drivers installed or required. With no driver conflicts the 1080's are working awesome.

Thanks to everyone for your suggestions. I can finally get back to work while I still have a little hair left.

Capture2.PNG
 
Last edited:

Squuiid

macrumors 68000
Oct 31, 2006
1,651
1,011
H
************************************************************************
I had to edit this post to say this. With the exception of FrancoisC who gave very good advice, the rest of you just told me to "Give UP". Well within 1 hour of posting my issue I had it resolved. GIVE UP is not a viable response for me. Yes, I wanted to give up for the last week but I thought I'd tap into some of the expertise available on this site I've been a member of for many years. Give up is the easy out but it doesn't work for me. The issue is resolved and I have FrancoisC to thank.
************************************************************************

Persistence pays off !!! It's all working now. After banging my head on my desk for a week swearing at Windows I finally got everything working together and can button up my machine.

This was the solution: When windows initially see's the GT120 card it identifies it as a VGA Compatible Video Controller. At this point everything is okay. But within seconds of booting to the desktop it attempts to install drivers for it and that's what brings down all three cards. I was finally able to get windows to STOP installing drivers automatically. The card stays as a basic VGA Video Controller with no drivers installed or required. With no driver conflicts the 1080's are working awesome.

Thanks to everyone for your suggestions. I can finally get back to work while I still have a little hair left.

View attachment 711246
How did you get Windows to stop installing the driver? I've found that Windows 10 will try, try and try again.
 

h9826790

macrumors G5
Apr 3, 2014
14,502
7,031
Hong Kong
H

How did you get Windows to stop installing the driver? I've found that Windows 10 will try, try and try again.
There was a post quite a few months ago mentioned about how to do that.

Anyway, how about disabling the hardware? If the GT120 is just there for boot screen (when needed), it doesn't really matter if the GT120 is disabled inside Windows, right?
 

Dr. Stealth

macrumors 6502a
Original poster
Sep 14, 2004
812
722
SoCal-Surf City USA
There was a post quite a few months ago mentioned about how to do that.

Anyway, how about disabling the hardware? If the GT120 is just there for boot screen (when needed), it doesn't really matter if the GT120 is disabled inside Windows, right?
So my issue was not about boot screens. I can get along fine without them just using BootChamp to bounce between Win 10 and macOS. I just wanted to keep all three cards in the box so it would be very handy to have boot screens (GT120) when needed without having to open my Mac and swap cards every time.

I tried several times to just disable the GT120 but whenever I would reboot win 10 it would be re-enabled and windows would be feverishly re-installing the bad drivers for it.

This is what finally worked to stop windows from installing the drivers. I used both Method 1 and Method 2 from this article.

https://www.drivereasy.com/knowledge/stop-windows-update-installing-drivers-in-windows-10-solved/
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.