12" Powerbook Won't Start With Battery

Discussion in 'Macintosh Computers' started by ftf1013, Oct 21, 2004.

  1. ftf1013 macrumors newbie

    Oct 21, 2004
    I just got a 12" refurb from Apple ...works great when plugged in to the AC. I charged the battery to 100% and was going to condition the battery by running only on the battery 'til it ran out of power.

    When I unplugged the AC from the PB it shut down abruptly. When I tried to power on it did so for about a second then quit.

    Is this a known issue with a well-known (but not by me) fix or does this sound like I got a bum battery?

    If no easy fix is know I'll be calling Apple for a replacement ...figure it's easier to try here first.

    Thanks for your help!
  2. ftf1013 thread starter macrumors newbie

    Oct 21, 2004
    Upon further review ...I'll give a PMU reset a try and see what happens.

    Any other suggestions are welcome and appreciated.

  3. cluthz macrumors 68040


    Jun 15, 2004
    If the pmu trick doesn't work, give apple a call..
  4. JFreak macrumors 68040


    Jul 11, 2003
    Tampere, Finland
    you emptied the battery, right? there's a known "feature" with albooks - the battery can run so dry it won't boot up until it has been charged a few minutes. it's perfectly normal and happens almost every time.

    just put the battery back in, charge it for few minutes (2-3 maybe, shouldn't take more than 5) and then power up the laptop.
  5. ftf1013 thread starter macrumors newbie

    Oct 21, 2004

    I ran the hardware test, re-installed OSX, removed the battery, reinstalled the battery, did the PMU trick and have improved battery performance by about one second.

    If I shut the PB down, unplug the AC and try to start the computer I get about a split second of start-up noise and the apple sound then nothing.

    I then started the PB with the AC connected and then unplugged the AC while PB was on. Power stayed on long enough after for the batter icon to go from AC to 99% before shutting off.

    Hate to think I gotta send this thing back but if any of this does not bring to mind anything I might have left out or overlooked then I guess I'll be callling for an RMA number from Apple. :(

    Thanks for the replies. Anything addition is appreciated.
  6. tdhurst macrumors 601


    Dec 27, 2003
    Phoenix, AZ

    Bad logic board. The exact same thing happened to my Rev B 17". Send it in now before something else goes wrong.
  7. ftf1013 thread starter macrumors newbie

    Oct 21, 2004
    Many thanks to all of you for your responces ...I'll be getting this back to Apple ASAP.

    Thanks again!
  8. spencecb macrumors 6502a


    Nov 20, 2003
    Just a thought....

    My PowerBook does this same thing, but its because I spilled liquid on it. It works off of the A/C power, but will immediately shut off if it is unplugged, and if you push the power, it will start to boot up for about 1-2 seconds, then shuts back off....so I don't know if this could have happened to your PowerBook, but I suppose it is a possibility
  9. ftf1013 thread starter macrumors newbie

    Oct 21, 2004
    Well, I didn't spill anything on it, but as a refurb, I guess anything could have happened to it to become a refurb before I got it!

    They're sending me a box and it'll be going back to Apple on Monday or Tuesday at the latest.

Share This Page