15" Powerbook Not Sleeping With Lid Closed

Discussion in 'Macintosh Computers' started by Elenita, Sep 30, 2004.

  1. Elenita macrumors member

    Mar 2, 2003
    Washington, DC
    Hello, everyone,

    I'm not sure when this started, exactly--I only noticed it today--but my Rev A 15" Aluminum Powerbook won't sleep when the lid is closed. I verified that my Energy Saver sleep settings are not set to never, and I also reset my Power Management Unit; no dice.

    Possibly relevant details:
    • Running Mac OS X 10.3.5
    • FileVault is enabled for my account
    • Sleep works fine if I hit the Power Button or choose that option from the Apple Menu

    Any help would be appreciated. Thanks!
  2. JFreak macrumors 68040


    Jul 11, 2003
    Tampere, Finland
  3. Elenita thread starter macrumors member

    Mar 2, 2003
    Washington, DC
    No, a USB one. I've been using it for as long as I've had this computer, and--as far as I can tell--this is fairly recent.
  4. Elan0204 macrumors 65816


    Apr 16, 2002
    Chicago, IL
    Do you still have the problem if you disconnect the mouse? What about anything else you may have plugged in?
  5. MacNut macrumors Core


    Jan 4, 2002
    My usb mouse shuts off when my computer goes to sleep so i don't think the usb is a cause of it, Is it possible that the latch is bad.
  6. Elenita thread starter macrumors member

    Mar 2, 2003
    Washington, DC
    I disconnected mouse and ethernet cord, but no luck.

    I'm also pretty sure that it's not the latch, because I had that recently repaired when I took it in for white spots; the entire LCD was replaced. Come to think of it--could that have something to do with my Powerbook insomnia?

    Thanks for all the suggestions; I appreciate it.
  7. alexf macrumors 6502a


    Apr 2, 2004
    Planet Earth
    Just be sure NOT to leave it closed for a long time if it is not sleeping.

    I'm sorry I can't give you any more advice.
  8. Rend It macrumors 6502

    Oct 27, 2003
    United States
    I also have a Rev. A 15" Al Powerbook, and I had the same problem a while back. I also had an issue with the Scheduler in the Energy Saver pane. I would set it to shut off (like a sleep timer) every night at around 1am. At 2am, I would wake to find iTunes still playing away, so I would have to select Sleep from the Apple Menu. I called Apple, and they really didn't know what was wrong (they just told me to try the usual resetting of the PMU and PRAM). After awhile, I realized that the problem went away if I would turn off my Bluetooth mouse whenever I wanted my PB to sleep normally.

    But, you said you don't have a BT mouse, and have already tried unplugging your USB mouse. I know this isn't helping much, but I also sent mine in for a compete replacement of the LCD and bezel. But, I think the sleep sensor is in the hinge, not the latch (someone else correct me if I'm wrong). Also, when your PB doesn't fall asleep, do you find it really hot to the touch? Mine would fry an egg if I closed the lid and forgot to turn off the BT mouse. (Note that I can leave the BT mouse on, and the PB sleeps fine if I always select Sleep from the Apple Menu).

    So, as I said, not much help. I pretty much gave up trying to find out what's wrong - now I just plug my iPod into my stereo and use its own sleep timer (much more effective!). I've avoided the problem, but if you need another voice to yell at Apple, I'm happy to oblige.

  9. kasei macrumors 6502a


    Dec 30, 2003
    Los Angeles, CA
    I was experiencing the same problem after I added the last security and java updates. I repaired permissions and the problems has gone away. I have a 17" PowerBook 1.33 GHz running 10.3.5....

Share This Page