2.2 has locked me out of my iPhone!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by teiresias, Nov 21, 2008.

  1. teiresias macrumors regular

    Joined:
    Oct 15, 2007
    #1
    So I started the firmware update than walked away to start some laundry and do some other chores. I come back to see the nice little "iPhone is activated" message and slide the slider to unlock.

    Then, much to my surprise my iPhone is asking me for a passcode - I didn't have one set up before, so I have no idea what number it could possibly be wanting me to enter!!

    Is this something a restore might fix? Any ideas? Thanks.
     
  2. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #2
    Sounds like you'll have to restore :(
     
  3. bbbullock macrumors newbie

    Joined:
    Nov 22, 2008
    #3
    You will have to take your iPhone to an Apple Store Genius Bar. This happened early yesterday when I updated my wife's iPhone to 2.2. After a couple of hours on the phone w/ AT&T and Apple's iPhone helpdesk, they determined that a Genius Bar appointment was required. When she got to the Genius Bar, they finally had to give her a new iPhone (after 45 minutes of the same troubleshooting that was done via phone)!

    Apple's iPhone help desk called us back several hours later to follow-up (excellent customer service) and let us know that her phone was the first one to experience this problem on upgrade...and that since then they have had the same problem with about 150 phones nationwide (probably higher by now).

    As of yesterday late morning they did not know what was causing the problem...but again, the only solution is an iPhone replacement.

    They handed her a new phone at the Genius Bar, moved service to the new iPhone, and gave her (easy) instructions on how to restore all of her settings, data, apps, etc. from iTunes when she got home. It all worked exactly as advertised.

    Although this was all frustrating, she gave Apple extremely high marks for how they handled the problem!!

    I was impressed that the Apple phone tech called ME back when it was all over, just to let me know what had happened.

    Hope your experience is similar.
     
  4. bbbullock macrumors newbie

    Joined:
    Nov 22, 2008
    #4
    One other point...the behavior my wife's phone exhibited was that it ONLY allowed her to place emergency calls. It did NOT give her the option to enter a passcode...as a matter of fact, it told her that it needed a password to unlock the SIM, but didn't give her a way to enter such password.

    If this is the behavior you're experiencing, then my notes above apply...otherwise, it is probably some other issue.
     
  5. Chris Albano macrumors newbie

    Joined:
    Dec 22, 2008
    #5
    My iphone locked me out.






    " i have this same problem, It didnt gave me an option to enter my passcode. I tried putting it on my computer so it can read it, but it tells me to enter passcode in order for itunes to read it. So i need help to get through my passcode. What do i have to do to get through this situatoin? I already brought it to apple, and they said its my responsibility, because of this hack, they cant do anything. " please help me, id appreciate your assistance.
     

Share This Page