2 iPhones, 1 work/1 personal. How do I keep my personal iMessages from going to work phone?

Discussion in 'iOS 9' started by audirs5, Feb 29, 2016.

  1. audirs5 macrumors 6502

    Joined:
    Oct 20, 2014
    #1
    Hello,

    Just wondering how I can keep my work iPhone from receiving my iMessages from my PERSONAL device.

    Do I,

    settings < messages < iMessages < Uncheck "you can be reached by message at "personal #"

    If I do this, will my other iPhones iMessage de-activate?

    Thanks
     
  2. Sleaka J macrumors regular

    Sleaka J

    Joined:
    Mar 5, 2015
    #2
    You use 2 different Apple IDs.

    I don't think there's any other way around it.
     
  3. bransoj macrumors 6502a

    Joined:
    Jul 31, 2013
    #3
    As i've mentioned on threads like this before we have three iPhones, mine plus my wifes personal and work iphones, all on the same apple ID. Under the Settings > Messages > Send & Receive just have it so only the devices phone number is ticked and then messages only go to that one device. We've been running like this for years now without any issues.
     
  4. Manatlt macrumors 6502a

    Joined:
    Aug 26, 2013
    Location:
    London, UK
    #4
    Just go to your work phone and uncheck your personal number there in the receive section. Done. I did this myself.

    (And no, it won't deactivate your personal number's iMessage)
     
  5. hwojtek macrumors 6502a

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #5
    No need to use two Apple IDs.
    On each phone select the appropriate phone number to receive messages to (Settings → Messages → Send & Receive).
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    I think this can happen if the person sending has intermingled your personal and work contact info into one contact.
     

Share This Page