3G connection dies periodically after jailbreaking - iPhone4 4.1 greenpois0n

Discussion in 'Jailbreaks and iOS Hacks' started by Eisenhorne, Oct 13, 2010.

  1. Eisenhorne macrumors newbie

    Joined:
    Oct 13, 2010
    #1
    I have just used greenposi0n to JB my iPhone4 yesterday. Everything works pretty well.

    However, I just noticed that every so often, my 3G connection simply dies. I have 3-5 bars of signal and the 3G word is on the status bar. But every app that tries to access the internet times out (this is especially noticable on Cydia. It fails to get an updated app list from the repos)

    If I turn off the 3G and then turn it on again, the issue is resolved. But this soon happens again. Reboot of course works as well.

    The following is the list of JB apps I've installed:

    biteSMS
    five icon dock
    lockscreen clock hide
    SBSettings
    Slanted Lock
    Typophone 4
    Winterboard

    Does anyone else have similar issues after JB'ing?
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Turn off all system mods. Install one at a time back (say, one per day), and test.
     
  3. Eisenhorne thread starter macrumors newbie

    Joined:
    Oct 13, 2010
    #3
    Which are considered system apps? Is there a way of disabling them without actually uninstalling them ?
     
  4. airtron macrumors newbie

    Joined:
    Jul 5, 2010
    #4
    I have the same issue and jailbroke using greenposi0n. The only similar apps I have are five icon dock, SBSettings, and winterboard. Maybe that will help narrow it down.
     
  5. Grayburn macrumors 68000

    Grayburn

    Joined:
    Jul 12, 2010
    Location:
    London, England
    #5
    I have this problem too and it also happens when 3G is off.

    It happened this morning before i had installed anything from Cydia.

    That narrows it down even more.
     
  6. hace macrumors newbie

    Joined:
    Sep 23, 2010
    #6
    I have a limera1ned and unlocked iPhone 4. Also installed
    sbsettings
    five icon dock
    and some other cydia apps.

    My 3G and GPRS connection isn't working.
     
  7. Eisenhorne thread starter macrumors newbie

    Joined:
    Oct 13, 2010
    #7
    Both your 3G and GPRS aren't working at ALL? Or is it like me, where it dies periodically?
     
  8. Shanewilliams macrumors 6502a

    Joined:
    Apr 3, 2010
    #8
    I jb with limera1n last night and had the same issues as the OP. I thought it had something to do with the commcenter hack but I guess not. My data connection would show up briefly but go away when I tried to use data. I finally just gave up and restored.
     
  9. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #9
    There are many threads on different Forums about those having problems with IP4 on 4.1 firmware and 1.59 baseband with the Ultrasn0w unlock. There does not appear to be a solution that anyone has found yet. It looks like ultrasn0w does not play well with 4.1 firmware. Planetbeing seem to have disappeared and is probably the person that needs to look at ultrasn0w.

    The problems appear to be an unreliable unlock or in some cases not working at all. I am sure there are those that will say it works for me. The fact is there are many crying out for help on different forums with unlock issues on ip4.

    Musclenerd has warned multiple times not to upgrade to 4.1 if you need an unlock but wait on pwnage tool. I guess even through we know that 1.59 is unlockable, it sounds a lot like his advise should be taken.
     
  10. Shanewilliams macrumors 6502a

    Joined:
    Apr 3, 2010
    #10
    I'm not sure about the other posters but I myself do not need a unlock. I just installed the commcenter hack(enable tethering) and had the issue so I restored, jb again, installed Cydia and almost the exact same apps as the OP and still had the same issue. I finally around 1am this morning got tired of dealing with it and just restored and left the jb out. I'm just going to go back to 4.0.1 when I get home and wait on a solution.
     
  11. NJRonbo macrumors 68000

    Joined:
    Jan 10, 2007
    #11
    Having the same problem.

    I may have to dump this 4.1 Jailbreak
    for now until a better one becomes available
    unless, that is, someone has a better solution.
     
  12. chakraj macrumors 65816

    chakraj

    Joined:
    Feb 6, 2008
    Location:
    So Cal
    #12
    I think Ill stick with 4.0.1 for a while, I guess untill Folder Enhancer comes out for 4.1. Maybe all the bugs will be worked out by then.
     
  13. taggozzo macrumors newbie

    Joined:
    Oct 16, 2010
    #13
    I had problems too

    With limera1n and tried to restore my iphone 4 and now im stuck in recovery mode...i tried with DFU mode and nothing! it gives me error: 1004!
    anyone can help?

    thanks a lot!
     
  14. NJRonbo macrumors 68000

    Joined:
    Jan 10, 2007
    #14
    By the way, just for kicks and giggles I
    restored my jailbroken phone and then did
    the jailbreak over using Limera1n.

    I now have 3GS.

    All is well. The jailbreak seems to work well.
     
  15. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #15
    It's normal, use TinyUmbrella to kick it out and it's fine.
     
  16. taggozzo macrumors newbie

    Joined:
    Oct 16, 2010
    #16
    i used tiny umbrella and now the phone is on SOS mode, only can make sos calls!
    any idea?
     
  17. Shanewilliams macrumors 6502a

    Joined:
    Apr 3, 2010
    #17
    Did you activate the phone through itunes?? It sounds like thats what you need to do.
     
  18. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #18
    This
     
  19. Eisenhorne thread starter macrumors newbie

    Joined:
    Oct 13, 2010
    #19
    FYI, i actually didn't use ultrasn0w or any unlock since I'm happy using the carrier where i got the iPhone4 from (in fact, i'm not even sure if it is locked. Is there anyway to check without inserting a microSIM from another carrier??)

    After a week or so of use, my 3G problems seems to have sorted itself out. No more connection not responding randomly. I have not uninstalled any apps for testing or anything like that (procrastination ftw! :p).
     

Share This Page