3G iPhone won't charge, stops playing music and no Sound through speakers Help please

Discussion in 'iPhone' started by SleepyHead157, Sep 27, 2008.

  1. SleepyHead157 macrumors regular

    Joined:
    Jun 10, 2008
    #1
    Hi, I wanted to see if anyone c an possibly help me before I head to the Apple Store tomorrow to get my 3G iPhone looked at. A few problems started to arise in the last few days.

    1) The iPhone won't charge. I tried 3 different USB cords, including the one it came with. Also tried two other wall chargers, one finally worked. Sometimes the cords work, other times they don't

    2) Sometime when I plug in a USB cord to charge, I get a message that says It's not a iPhone Accessory and asks if I want it to be put into Airplane Mode. The same thing happens sometimes when I plug in my Apple earphones. After taking them out and plugging them back in, it works but 10 minutes later the music stops and the message pops up again

    3) I don't hear music coming out the speakers on the iPhone. I can hear an incoming call but no text messages or music or from the movies I have on the iPhone.

    I restored 3 times already, twice this morning and the problems keep happening. I set up an appointment with the Apple Store tomorrow, but would like to avoid the trip if I can get some solutions. Thanks
     
  2. deannnnn macrumors 68000

    deannnnn

    Joined:
    Jun 4, 2007
    Location:
    New York City & South Florida
    #2
    When you restore, do you restore from one of your backups? Or do you restore clean?
     
  3. SleepyHead157 thread starter macrumors regular

    Joined:
    Jun 10, 2008
    #3
    From backup
     
  4. Opie macrumors 6502a

    Opie

    Joined:
    Jun 17, 2008
    #4
    Do a DFU restore and then set up as new iphone.
    1. Power your phone off
    2. Hole down the sleep wake button and home button till apple appears (10 sec)
    3. Release the Sleep wake button and continue to hold home button for 10 seconds.
    4. Restore it
    5. Set up as New Iphone then resync everything and see what happens.

    Good Luck
     
  5. neesh0 macrumors 6502a

    neesh0

    Joined:
    Sep 6, 2008
    Location:
    Toronto, Ontario
    #5
    A clean restore may only fix a few problems, but the charging problem may be a hardware fault
     
  6. deannnnn macrumors 68000

    deannnnn

    Joined:
    Jun 4, 2007
    Location:
    New York City & South Florida
    #6
    Sometimes when you restore from backup, you are basically telling iTunes to put your problems right back on the phone because they are actually stored in the backup.

    Try doing a clean restore to see if it fixes your problems.

    I know it's annoying... but I don't think you have any other options at this point =/
     

Share This Page