3GS 4.2.1 - No MMS/can't restore over greenpois0n ipsw (error 29 itunes)

Discussion in 'Jailbreaks and iOS Hacks' started by kylezo, Jun 23, 2011.

  1. kylezo macrumors newbie

    kylezo

    Joined:
    Jun 23, 2011
    #1
    Hello everyone!

    I could really use some help. I got a jailbroken 3GS from craigslist recently, and I have learned that the previous owners had the battery replaced. When I got the phone home, I decided to wipe it and jailbreak it myself.

    So I go into iTunes to restore to 4.2.1, planning to redsn0w JB afterwards. i get a 16xx error...nothing unexpected. I get back into the shift+restore process and this time, I get an error 29. Did some research and found that this is a hardware error usually relating to the battery. At this point I couldn't get anything, jailbroken or not, onto the phone to get it running again. So, I download every jailbreaking and modding program I can find to try and get it working. Eventually, using greenpois0n, I was able to get the phone running. This whole process took me about 6 hours.... yikes. At first, after finally getting the phone running, I had no service. Used multiple SIM cards that worked in other phones, etc. AT&T said the phone wasn't showing up on it's towers at all...eventually I went through the restore/16xx/29/greenpois0n process again to get it back up and I had service.

    So finally the phone is working (4.2.1 greenpois0n). I wanted to restore on top of the greenpois0n install, cuz I don't like the little custom boot logo, and I don't really know jack about greenpois0n or how it works. But, I am repeatedly frustrated by the error 29, so I settled for it.

    Now, I'm having problems sending and receiving MMS picture messages. I don't know what's wrong but I've been on the phone with AT&T already and everything 'seems' to be correct. I presume it's a software problem because of the weird setup process I had... I will get a 'message' when someone sends me a picture, but it's just the little arrow, and no thumbnail, and when I click the arrow its just a blank screen where the picture should be.

    ****tl;dr****
    I can't send/receive MMS messages and I'm not confident I can restore/re-jailbreak correctly...

    SO, now you know a bit of the history, I'm hoping someone can help me out with some info. Why is greenpois0n able to bypass/work around this hardware fault error from iTunes? Is there an alternative program I can use to restore a default Apple ipsw and jailbreak cleanly through redsn0w? Any other ideas as to what might be up with my MMS? Any advice on a procedure to correctly update/shift-restore without 16xxs or 29s? I have used iREB to get pwndDFU mode running but it never helps. The only thing that gets past 16xx for me (and subsequently into 29) is task manager/kill itunes.exe, then reopen and shift-restore again.

    I'm running on Windows XP, latest iTunes, and I have a buttload of ipsw's and SHSH's through tinyumbrella.

    Sorry for being so lengthy...but I wrote a tl;dr summary so there :p

    Thanks for any help!

    Kyle
     
  2. Epic Orange macrumors member

    Epic Orange

    Joined:
    Jun 7, 2011
    Location:
    Element X
    #2
    This should help: http://www.youtube.com/watch?v=kBLfU1XVmmY&feature=iv&annotation_id=annotation_220295

    I suggest restoring clean to official Apple Firmware iOS 4.2.1. After that, you should use the video to jailbreak.

    Lesson be learned however. Jailbreaking is fun when everything is fun and works, but when something goes wrong, it sucks.
     
  3. kylezo thread starter macrumors newbie

    kylezo

    Joined:
    Jun 23, 2011
    #3
    Thanks for the reply Epic! As I said in my original post, I tried restoring through iTunes to official 4.2.1 ipsw, but I got 16xx and 29 in the process and the phone no longer functioned properly. Greenpois0n was the only thing that got it up and running again, somehow >.> And I certainly thought I learned that lesson with my last iPhone, but running into the unexpected hardware error is teaching me all over again..hahaha.

    I'm waiting for a phone number of the *guru* that the last owner paid to switch out the battery so I can let them do me the favor of putting the right battery in here. I'll keep you updated...

    Thanks!
     
  4. tcouto macrumors newbie

    Joined:
    Sep 6, 2010
    #4
    Whats your baseband? might it be 6.15?
     
  5. kylezo thread starter macrumors newbie

    kylezo

    Joined:
    Jun 23, 2011
    #5
    No, its 5.14.02 :eek:
     
  6. tcouto macrumors newbie

    Joined:
    Sep 6, 2010
    #6
    Lucky you ;) 6.15 would explain the problems you were having going to stock firmware...
     
  7. kylezo thread starter macrumors newbie

    kylezo

    Joined:
    Jun 23, 2011
    #7
    True that, it would have. I have read a little that has mentioned that you can't restore factory FW on top of a JB device...I'm not sure how that works. I have all my SHSH's and I had tinyumbrella server running...but whateva. I should be getting my info for the people who changed the battery soon and I'll have it out with them to get a *real* battery in this beast. Then to get FF7 running at 60fps... lol
     

Share This Page