3GS on ios 3.1.3 and Baseband 05.12.01....Safest way to unlock and jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by nickosbad, May 27, 2011.

  1. nickosbad macrumors regular

    Joined:
    Feb 16, 2009
    #1
    Hi all

    I have recently aquired an old 16GB 3GS to use as a spare phone, I jailbroke my old 3GS a few years ago but need some advice on this one as it is a while since I did it

    It is currently running ios 3.1.3 and the modem baseband is 05.12.01 which looks like it is unlockable BUT which is the best way to go about this??

    Also is there any way to upgrade to ios4 and retain the unlock??

    The web is full of loads of info but I can't filter out the info I need

    Thanks

    Nick
     
  2. jkeating2005 macrumors regular

    Joined:
    Mar 27, 2009
    #2
    1. Download either Pwnage (mac) tool or sn0wbreeze (windows) and create a custom firmware.

    2. put the phone in pwnd DFU mode and restore using the custom firmware you just created.

    3. Finally download ultrasn0w from cydia.

    ...as simple as that
     
  3. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #3
    I would suggest using SnowBreeze. PwnageTool would be your best option if you have a Mac. Or have a friend create a custom firmware for you using Pwnage.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  5. nickosbad thread starter macrumors regular

    Joined:
    Feb 16, 2009
    #5
    Yep i'm using a Mac

    Which version of firmware should I use (to enable a carrier unlock) with Pwnage tool to create the custom one?? i.e. can I get IOS4 this way?

    I think I used this process when I had my 3GS originally but I had no need to unlock it back then

    Cheers
     
  6. nickosbad thread starter macrumors regular

    Joined:
    Feb 16, 2009
    #7
    Cool, so just to check (because the tutorial says its for an iphone 4 not a 3gs), if i follow this tutorial it will put me on 4.3.3 and will still allow me to unlock with ultrasn0w??
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Yes, if you follow it correctly you will be on the latest 4.3.3 with an unlockable baseband.
    All you have to do after is open up cydia and install ultrasnow to unlock it.
     
  8. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #9
    I hate to mention this, but I've seen this happen too often.:rolleyes:
    Don't upgrade first. Use pwnage tool's custom file to upgrade your phone.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Yes, never update to official firmware if you want to keep your unlock.
     
  10. nickosbad thread starter macrumors regular

    Joined:
    Feb 16, 2009
    #11
    Ok, I ran Pwnage with the supplied link but the iPhone rejected it because it was for an iPhone4, anyway I re built an ISPW with the correct version of 4.3.3 but I am now getting an error 1601 message when the restore starts

    Any suggestions??
     

Share This Page