3gs-wanted to downgrade, but need to restore on 4.2.1-failure from custom ipsw

Discussion in 'Jailbreaks and iOS Hacks' started by threetimesdaily, Dec 16, 2010.

  1. threetimesdaily macrumors member

    Joined:
    Aug 30, 2010
    #1
    i've been trying to get my iphone working for a really long time, but having no luck.

    ive got JB 3gs new bootroom on 4.2.1

    my phone isnt activated with itunes so i need to restore, but cannot do it.

    i have old shsh blobs on cydia including 4.0.1 which is what i'm trying to downgrade and restore to.

    i followed steps to edit hosts file to connect to cydias server
    -how can cydias server see my iphone if its in DFU mode? do i need to create custom ipsw for 4.0.1 while "tether boot"ed on pwnage tool?

    pwnage tool says "wrong ipsw bundle" everytime i try to create custom ipsw, except for 4.2.1, so i made custom ipsw for 4.2.1 just to try to restore.

    when i tried to restore to custom 4.2.1, i got a general error message after attempting to restore. from my understanding, this always happens so you just run recboot and it should restart fine. recboot didnt work so i repeated process, except after error message i used pwnage tool to boot tethered. once booted i tried restarting iphone hoping that it would be restored. it was not restored.

    i really dont understand why it wont restore with a custom 4.2.1 ipsw. I'm obviously not connected with cydias servers if pwnage tool doesnt allow me to create custom ipsws from shsh blobs i have on cydia, so downgrading is less important to me than just restoring. i want to be able to use itunes again more than anything else
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    When you edit your host file, it tricks iTunes into connecting to Cydia instead of Apple's servers. This then allows you to downgrade to an older firmware if you had old SHSH files saved on Cydia.

    Since you have 4.0.1 SHSH files saved and to restore to that firmware, 1) download the official 4.0.1 firmware file, 2) edit host file and 3) through iTunes, restore with the the 4.0.1 file.

    If you want to restore with a custom 4.2.1 firmware, 1) have custom firmware file, 2) you must use Pwnagetool or Redsnow to put phone in a special DFU and 3) restore through iTunes with custom file.
     
  3. threetimesdaily thread starter macrumors member

    Joined:
    Aug 30, 2010
    #3
    I tried doing that but I get an error message after attempting to restore (restoring on custom 4.2.1) in DFU mode through pwnage tool.

    shouldnt my iphone also be able to restore in DFU mode with the regular 4.2.1 ipsw file too even though its jailbroken?

    I asked apple about a hard restore using combinations of home/power buttons, but thats not possible. I thought I read in a forum that there was a way to do that. If none of these methods worked could my phone be shot?
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    What's the error you are getting? If you are restoring to latest firmware (4.2.1), your host file doesn't need to be edit or have Tinyumbrella running. Have you tried a different USB cable, USB port, reinstall iTunes, disable any security programs, and if all else fails, try on another computer?
     
  5. threetimesdaily thread starter macrumors member

    Joined:
    Aug 30, 2010
    #5
    i was able to restore it on windows xp itunes 10. after restored, i tried to hook it up to my mac, but it needed to restore to activate. i tried to do a normal restore but itunes says:

    "The iPhone "iPhone" could not be restored. An unknown error occured (1611)."

    im thinking that after editing my host file to cydias server, and then trying to edit it back to apples server, i must have made some errors. if my host file is not accurate with apples server, then I wouldnt be able to do a standard restore correct?
     

Share This Page