4.2.1 -> iOS 5 [have iOS 5 ipsw but no go]

Discussion in 'iPhone' started by patent10021, Dec 28, 2011.

  1. patent10021, Dec 28, 2011
    Last edited: Dec 28, 2011

    patent10021 macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #1
    Do I need to upgrade to 4.3.3 or 4.3.5 first before iOS 5? I thought with the ispw file on my desktop I could just upgrade from 4.2.1 manually but getting errors. It's upgrading directly via apple.itunes but I can't see what version it's downloading. Wondering if it's iOS 5 directly. Doesn't really matter since it's working but I'd like to do this manually.

    Thanks

    update: finished 4.2.1 to iOS 5 all in one swoop but I'm still wondering why I couldn't do it with the ipsw file. Anywhoo.

    .
     
  2. screensaver400 macrumors 6502a

    Joined:
    Jan 28, 2005
    #2
    Were you trying to use a 5.0 or a 5.0.1 IPSW? 5.0 can no longer be installed, unless you took some steps before 5.0.1 was released that would allow you to keep installing 5.0 in the future.
     
  3. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #3
    Just connect to iTunes and press the update button. It should download the correct build/version for you.
     
  4. patent10021 thread starter macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #4
    Ah that's why. Interesting. So they don't require incremental updates like they used to.

    As mentioned above, already updated fine via iTunes.
     

Share This Page