4s (5.0.1) Security Flaw? Bypass Passcode Lock with Incoming Call

Discussion in 'iPhone' started by huyrich, Apr 9, 2012.

  1. huyrich macrumors newbie

    Joined:
    Oct 14, 2011
    #1
    My 4S is jailbroken but can someone with non-jailbroken one try this too? I have tested it extensively and it works every time if you do the following (strictly):

    Presets:
    - Settings -> General -> Passcode Lock set to ON, Simple Passcode, Require Passcode after 1 min (just to make the test faster, doesn't seem to work with immediately setting).
    - Auto-Lock set to 1 min (again, to make the test faster)
    - Let the phone idle and timeout both the auto-lock and passcode lock period (> 2 mins, I did wait longer to make sure).
    - Do NOT wake it up by pressing anything. It won't work if you wake it up to verify that the passcode is in place. It should be if you wait long enough.

    Bypass Passcode:
    - Make a call to that (now supposedly locked) phone.
    - Answer it. Hang up. After the call ends, the screen should go black, immediately press the home button to turn on the screen, slide to unlock and now you're in the homescreen without having to enter any passcode.


    Other Possibilities:
    But then again, I have a lot of tweaks, so if this doesn't work for anyone, I need to find out what tweak is causing this. From the top my head, these could be the culprits: LockInfo & its widgets.
     
  2. Tinmania macrumors 68040

    Tinmania

    Joined:
    Aug 8, 2011
    Location:
    Aridzona
    #2
    For the record, doesn't happen on my 4S. And it is jailbroken on the same firmware.



    Mike
     
  3. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #3
    Just tried it. 4S 16gb iOS 5.1

    It locked as it should.
     
  4. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
  5. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #5
    This came up a while back, and I tried it with mine and it didn't work for me as well as everyone else.
     
  6. huyrich thread starter macrumors newbie

    Joined:
    Oct 14, 2011
    #6
    Thanks for trying. It must be a Cydia app then. Funny thing is it doesn't work with Immediate passcode requirement, or if you wake it up at least once before trying. Anyone has any idea?
     

Share This Page