4S only shows a few songs of the library even though Match is turned on

Discussion in 'iOS 7' started by pullman, Oct 7, 2013.

  1. pullman macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #1
    I have Match turned on since several months and the music has uloaded properly (though it did take some time). I have no problems playing the music on me computer but on my 4S I only see a part of my music, some 500 songs out of 15000. I'm not sure what could cause this. I've tried turning Match on and off without improvements. It was like this also on iOS 6.

    In case it is relevant I am having trouble downloading the songs which are shown over 3G (I do click the message that I wish to download over cellular). I tap to download and the cloud becomes a stop button with a ring around but ther download doesn't start.

    Would be grateful for any suggestions.

    Thank you
    Philip
     
  2. jhuynh macrumors member

    Joined:
    Oct 18, 2012
    #2
    Did you make sure that "Use cellular data" is turned on in Settings -> iTunes & App Store?
     
  3. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #3
    On desktop iTunes you can create a smart playlist for songs that aren't in iCloud. Make one of these, and it'll show you what's not in iCloud and it should tell you why.
     
  4. jsf8x macrumors 6502

    jsf8x

    Joined:
    Feb 28, 2010
    #4
    I'm also having this problem. It just started happening to me last week and my iPhone only shows 1 song out of my 6,000 song library. iTunes Match is turned on and everything.
     
  5. pullman thread starter macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #5
    Aha! Another setting I wasn't aware of. This was not on in fact. Turning it on made the download function work.

    And it now says that iTunes Match is loading. Fingers xed it'll all be ok!

    THANKS
    p
     

Share This Page