4S wifi not working.

Discussion in 'iPhone' started by Tronic, Feb 7, 2012.

  1. Tronic macrumors 6502

    Tronic

    Joined:
    Jun 10, 2009
    #1
    For some reason my 4S isn't connecting properly to my linksys router. I want to get an aebs but for now I just want to figure out whats wrong. I've reset things multiple times and have "forgot" the network and re-entered my ssid already. I have 2 MBPs, ipad and windows pc all connecting via wireless fine. my 4s works fine on wireless at work and school.

    Any idea whats wrong? did somehow my iphone get blocked from the network?
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    You don't enter your ssid. That is set at the router. You need to enter your routers password to connect.

    If you've done this and it still fails to connect, shut down and reboot your modem and router, waiting at least a minute before re starting them.
     
  3. aztooh macrumors 6502a

    Joined:
    Jul 5, 2011
    #3
    I've been having issues with WiFi on my 4S as well. Webpages and applications become unresponsive and I toggle the wifi on/off (boy, wouldn't a toggle in the notification center or on a homescreen be nice?) to get it working again. Sometimes it works, sometimes it doesn't and I restart the phone.

    However, just yesterday I got a new problem with it. I knew my wifi was on, but the icon wasn't there. So I went into settings and WiFi was grayed out and on the right it said "No Wi-Fi". Obviously the phone has WiFi capabilities, so seems like there's an issue brewing. Was also an issue with my iP3g near the end of it's life.
     
  4. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #4
    (Sure, a toggle would be nice, but isn't necessary, as it is easy enough to navigate to the WiFi settings.)

    Have you tried a reset of your network settings, a soft reset, toggling airplane mode on and then off, re-seating your SIM card, or any combination of these?
     

Share This Page