Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

5.1 Sound Issues

stocklen

macrumors regular
Original poster
Sep 25, 2013
120
58
Hi All

For the last couple of months Ive begun to notice a weird and annoying sound issue from the 4K AppleTV.

I want my appleTV to be my sole Settop Box, and its so nearly perfect.... Im in the UK and it caters for almost all the Streaming services and catchup services we have here.... the glaring omission being NowTV - yes I know there is a NowTV app but its woefully out of date and terrible to use.. however it is about to get a long needed update which should solve all the issues.

Anyway, I digress.

I was watching Netflix a while back and noticed that the sound was a little flat, and it turned out the the show that was supposed to be in 5.1 was not... I verified this with my Sonos app (I have a Sonos Beam with surrounds) and it was reporting a 2.0 sound signal. I tired another show in the Netflix app, and the 5.1 was working fine. Strange. I then switched over to my Fire Stick 4K, and tried the same episode and this time the 5.1 worked fine. Same episode.


I tired to raise this with Netflix and they didnt seem too interested in the problem and ive not heard anything back from them since.

The problem has persisted and if anything is getting worse. Things that are supposed to be 5.1 are only 2.0 but ONLY on the AppleTV's Netflix app and not the Fire Stick's app.

The problem is now seeming spreading... I was recently watching a show on Amazon Prime, and again I noticed that it was supposed to be 5.1 but I was only getting 2.0 out from the AppleTV.

I have done many experiments with settings, cabling, HDMI port swapping.... but nothing is conclusive at all.

What is particularly annoying is that some shows from Netflix work fine, and some do not. It is not the case that the entire Netflix app on the appleTV is not outputting 5.1 because it is. Other things outside of the Netflix app (and Amazon prime video) are perfectly fine. Purchased movies on iTunes are consistently 5.1 and the sound output works flawlessly.

This is so frustrating. I need my AppleTV to be my only Settop box... but I find myself having to resort to the Firestick more and more often now.

Has anyone else experienced similar problems? Did anyone find a solution?
Is it the app? Is it the hardware?

Maybe TVOS 14 will solve the issue. Who knows. Maybe I should do a factory reset?

Any advice on solutions or troubleshooting would be most appreciated.
 

philrock

Contributor
Jul 5, 2015
154
55
Oxnard, CA
Any resolution or update to this?

I've very recently started having sound issues with my AppleTV and Sonos system. Audio gets out of sync regularly now. For several months I had a 5.0 with a Beam + Play:1s and experienced no issues. A few months ago I added a Sub gen3 and have noticed the sync becoming more of an issue. It didn't start right away though which makes me think it is an AppleTV issue.

The fix requires an AppleTV RESTART. I have to do it every other time I watch TV.
 
Comment

stocklen

macrumors regular
Original poster
Sep 25, 2013
120
58
Any resolution or update to this?

I've very recently started having sound issues with my AppleTV and Sonos system. Audio gets out of sync regularly now. For several months I had a 5.0 with a Beam + Play:1s and experienced no issues. A few months ago I added a Sub gen3 and have noticed the sync becoming more of an issue. It didn't start right away though which makes me think it is an AppleTV issue.

The fix requires an AppleTV RESTART. I have to do it every other time I watch TV.

No... sadly.

this is a real problem. Its making me fall out of love with my AppleTV.

I was hoping that TVOS 14 would have fixed things but still the same.

My problems are random, and regular... and its got to the point where im getting some apps not working at all, some with the centre channel missing, some with 2.0 where it should be 5.1

That being said I have found a workaround.. but its not ideal. As soon as i 'deactivate' atmos - everything starts to work properly... albeit in 5.1 only.

With Atmos enabled in settings.. the ONLY thing that was working CORRECTLY was via the apple TV app... watching Apple's own content - I was watching Spider Man Far From Home... a movie I purchased on iTUNES and that worked perfectly AND output in atmos...... but literally nothing else on the AppeTV from any other app such as Amazon prime or Netflix would work in 5.1.

So now... I have the AppleTV set to 5.1.... and should I want to watch a movie I own in atmos, i just change the setting back for that viewing.... however I cant watch Netflix in atmos, nor Prime. This is such a frustrating problem to troubleshoot as it "works" fine... just not in all apps.

Ive not had these problems before.. but ive only just got the Sonos ARC. Before i had the Sonos Beam with no issues but of course didnt have atmos enabled until I connected the arc.


Interestingly, and annoyingly... I also have a Fire Stick 4K and that has no problems outputting its prime content AND netflix context in Atmos.

This really needs fixing.
 
Comment

waw74

macrumors 68040
May 27, 2008
3,708
432
I want to say I just saw something about this or similar, and there was a setting in the television that fixed it

on my LG CX oled, it's in the main settings -> sound -> additional settings -> digital sound out

I have mine on auto, but might want to play with the settings and see what happens.

the aTV actually re-packages into LPCM instead of sending straight dolby digital.
so if your TV is taking the LPCM and doing more with it, it could cause problems.

try googling your TV maker and LPCM, it might point you the correct direction.
 
  • Like
Reactions: philrock
Comment

JasonHB

macrumors 6502
Jul 20, 2010
329
226
Warwickshire, UK
No... sadly.

this is a real problem. Its making me fall out of love with my AppleTV.

I was hoping that TVOS 14 would have fixed things but still the same.

My problems are random, and regular... and its got to the point where im getting some apps not working at all, some with the centre channel missing, some with 2.0 where it should be 5.1

That being said I have found a workaround.. but its not ideal. As soon as i 'deactivate' atmos - everything starts to work properly... albeit in 5.1 only.

With Atmos enabled in settings.. the ONLY thing that was working CORRECTLY was via the apple TV app... watching Apple's own content - I was watching Spider Man Far From Home... a movie I purchased on iTUNES and that worked perfectly AND output in atmos...... but literally nothing else on the AppeTV from any other app such as Amazon prime or Netflix would work in 5.1.

So now... I have the AppleTV set to 5.1.... and should I want to watch a movie I own in atmos, i just change the setting back for that viewing.... however I cant watch Netflix in atmos, nor Prime. This is such a frustrating problem to troubleshoot as it "works" fine... just not in all apps.

Ive not had these problems before.. but ive only just got the Sonos ARC. Before i had the Sonos Beam with no issues but of course didnt have atmos enabled until I connected the arc.


Interestingly, and annoyingly... I also have a Fire Stick 4K and that has no problems outputting its prime content AND netflix context in Atmos.

This really needs fixing.

Are you running the HDMI from the Apple TV to the TV and then from the TV to the ARC?

If so, I wonder if the Sonos ARC supports Linear PCM which is what the Apple TV uses when in the higher quality audio mode or even if the TV is allowing that to pass through?

When you put the Apple TV in 5.1, it’s using a Dolby Digital bitstream which will be supported.

What TV are you using?

UPDATE - just confirmed that the Sonos Arc does NOT support linear PCM. The problem is not with the Apple TV but with the Sonos itself.

Jason
 
Comment

waw74

macrumors 68040
May 27, 2008
3,708
432
If so, I wonder if the Sonos ARC supports Linear PCM which is what the Apple TV uses when in the higher quality audio mode or even if the TV is allowing that to pass through?
it worked fine before the latest software updates on the aTV
 
Comment

waw74

macrumors 68040
May 27, 2008
3,708
432
I have an Arc, it does work.
The TV must support it also. It's possible you might also need an HDMI cable upgrade depending on what you were using.

My TV has settings that could potentially prevent it from working properly. not sure if other makes/models do or not.

I have also recently changed from a Beam to an Arc. I had to upgrade my TV to make atmos work.

If your TV doesn't support E-ARC it gets a bit confused. When I had my old TV, Atmos would randomly pop up in the aTV settings or media info pages, but it never actually put out the correct sound until I upgraded my TV.

I stupidly upgraded to beta 14.2, thinking it might fix some issues I was having in 14.0, it didn't fix anything and just broke additional things, so I currently have no Atmos from any app on the aTV, but Atmos has worked in the past. both on 13.x and 14.0

I have literally just checked this with my hands on the actual product
The sonos app reports "Dolby Multi-channel PCM 5.1" when playing 5.1 or atmos.
before I did the 14.2 upgrade, it reported atmos where appropriate.


Both TVs have been LG OLEDS, I went from an E6 to a CX


---- update Sep 30
Just did the update to the new 14.2 public beta that came out today

I have 5.1 in Netflix where appropriate (tried with good place) Arc reports "Dolby digital 5.1"
The setting mentioned above has to be on pass-thru or auto. If it's in PCM, then the Arc only reports stereo.
(main settings -> sound -> additional settings -> digital sound out)

I also now have atmos where appropriate, tested using Away on Netflix, and Greyhound on aTV+
 
Last edited:
Comment

stocklen

macrumors regular
Original poster
Sep 25, 2013
120
58
glad its working for you.

I have an almost identical setup though.

I have an LG OLED B9 from 2019 but purchased this recently due to its addition of an eARC knowing the sonos ARC was forthcoming for me.

I also replaced all my HDMI leads with new guaranteed HDMI 2.1 compatible ones.

The fault is somewhere... maybe in the LG. Maybe in the APpleTV... Maybe in the Sonos ARC. Theres a thread on it not supporting LPCM on the Sonos message boards - although we live in hope that Sonos makes a software update that fixes this.

Its frustrating as this setup is "supposed" to make things easier for the consumer... HDMI to TV, and ARC out to atmos soundbar.... instead its anything but simple.



As @JasonHB just said.. its more likely to be the fault of the ARC right now.


I just dont understand why I get perfectly fine ATMOS from the iTunes content... but not via other apps on the AppleTV.
 
Comment

waw74

macrumors 68040
May 27, 2008
3,708
432
have you looked in sound settings on the television?
to see if the same setting exists on the B9

if I set that setting incorrectly, I can make my TV behave like yours
I believe it defaults to a setting that does not work.
 
Comment

stocklen

macrumors regular
Original poster
Sep 25, 2013
120
58
have you looked in sound settings on the television?
to see if the same setting exists on the B9

if I set that setting incorrectly, I can make my TV behave like yours
I believe it defaults to a setting that does not work.

Indeed - checked all that.
The settings aren't that convoluted really and can be checked quickly.

The weird thing happening to me right now.. is that my Amazon Prime app is not play ANY centre channel sound. I have no dialogue whatsoever from this app. Just this app mind... not Netflix or any others.

In order to watch Amazon Prime content I have to resort to my Fire Stick.

Ridiculous.
 
Comment

Alan Gordon

macrumors 6502
Sep 29, 2014
403
270
Dawson, GA
I have an Apple TV 4K plugged into my TV via HDMI, and Optical Out via the TV into my AVR.

As of the 14.2 beta, I'm getting MAJOR audio syncing issues with audio not syncing up with lips.

As of the first beta, I could go into audio settings and switch to downconverting audio to Dolby Digital 5.1, and that seemed to fix it. However, the second beta of tvOS 14.2 has Dolby Digital 5.1 not even working right.

Stumbled upon this thread when seeing if anyone else was experiencing issues.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.