500gb WD My Passport suddenly not recognized, won't reformat,says 2TB in Disk Utility

Discussion in 'Mac Basics and Help' started by jennifer3241, Mar 16, 2010.

  1. jennifer3241 macrumors newbie

    Joined:
    Mar 16, 2010
    #1
    Hello!

    I recently purchased a 500gb Western Digital My Passport Elite external hard drive for my MacBook Pro. Since I run both Windows and Mac OS Version 10.4.11 on my MBP I wanted the drive to be readable and writable for both operating systems. When I connected the drive for the first time in the Mac OS it was recognized in the Finder but was not writable. So I followed the advice of a few forums and opened the Disk Utility and reformatted the drive for "Mac OS Extended (Journaled)". Things appeared to run smoothly, and I even copied about 10gb from my old external onto the My Passport. I did not use the drive until a few days later when I connected again running in Mac OS, but this time an error message popped up: "The disk you inserted was not able to be read by this computer." The drive did not appear in My Computer when I switched to Windows. Switching back to Mac OS and opening the Disk Utility I figured I may as well try again to reformat the drive again, this time receiving the error: "Disk Erase failed with the error: Input/output error". I tried formatting with each volume format from the drop-down and got the same error. I then tried partitioning the drive (with 1 partition) and clicking on "GUID Partition Table" in the Opitions dialogue box and received this error: "Partition failed with the error: Input/output error."

    It should also be noted that when I first connect the drive it makes about 6 clicking sounds as it is trying to boot and then sounds like it turns off when the "The disk you inserted was not able to be read by this computer" comes up. ALSO... which is really strange... the drive comes up as "2.0 TB WD My Passport" in the Disk Utility. I don't understand why this is as it is a 500gb drive. I do remember seeing it as a 500gb drive when I opened the Disk Utility the first time I successfully reformatted the drive.

    What is going on!? Any help would be greatly appreciated. Thanks!

    Jennifer

    [​IMG]
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Honestly I would probably warranty the drive at this point if it is still eligible. Pulling the drive and putting it in another enclosure or using a different SATA interface are valid options but that will void whatever remaining warranty there is on the drive. If it's OOW, test away...

    As far as root causes are concerned, I have a one to offer: Has the drive been properly disconnected/unmounted before the USB cable is disconnected?
     
  3. jennifer3241 thread starter macrumors newbie

    Joined:
    Mar 16, 2010
    #3
    Not sure what you mean exactly since it was only recognized the first time I plugged it in. Pretty sure I wouldn't disconnect without ejecting it first... but because it does not appear in the Finder anymore I have not properly ejected it since.

    Also, I received it only a week ago. Has a 6 month warranty.
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Ah I had assumed you had disconnected/reconnected it multiple times. The same way that you're supposed to use the Safely Remove Hardware taskbar icon on a Windows system before disconnecting a removable disk, you're supposed to drag the icon for the drive to the Trash to unmount it on OS X before you remove the physical connection. I still stand by my recommendation to return the drive for another. I/O errors are bad juju.
     
  5. jennifer3241 thread starter macrumors newbie

    Joined:
    Mar 16, 2010
    #5
    I purchased it online from a random site and received it about a week ago. I have contacted WD and am waiting for a response to see what they think the problem is. I figured if it was something stupid I did on my end when reformatting I would see if I could correct it myself. Thanks for your input!
     
  6. pcman2000 macrumors newbie

    Joined:
    Feb 21, 2010
    #6
    Did you says that it made Clicking sounds?
    "The Click of death" norally means that the HDD is Failing:eek:
     
  7. jennifer3241 thread starter macrumors newbie

    Joined:
    Mar 16, 2010
    #7
    Yeah it's a pretty loud succession of clicks, with about a 2 second interval between them. Sounds like it's trying to rev-up, but then clicks forcefully. After about 30 seconds of this it stops making noises and gives me the disk error.
     
  8. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #8
    Personally, I wouldn't ever trust the drive again anyway, so you might as well return it and get it replaced under warranty
     
  9. jennifer3241 thread starter macrumors newbie

    Joined:
    Mar 16, 2010
    #9
    Just a bit of an update: After giving me instructions on how to reformat my drive and me explaining again that it won't let me reformat, WD has given me an RMA # to replace the drive. They also said this, "After verifying the picture yet again we see that the drive is displaying the wrong amount of space. Which means that the firmware of the drive may be damaged. Since this is the case then unfortunately the only option is to replace your unit."

    Thanks for all your help!
     

Share This Page