5s randomly deciding it isn't compatible with my car stereo.

Discussion in 'iPhone' started by Xandros, Aug 4, 2014.

  1. Xandros macrumors regular

    Joined:
    Sep 19, 2010
    #1
    Here's a weird one, sometimes I'll plug my iPhone 5s into my radio via it's USB input, it'll work fine for about five minutes then all of a sudden the music stops and the radio displays a "read failed" error on the screen while my iPhone does nothing out of the ordinary. However the only way I can get the two playing nice again is if I turn the phone off and back on. Usually after that they'll work in harmony for a week or so before it does it again... Any insight into this?

    The radio is a few years old but it has full iphone/ipod control support via usb (though its rated to work with up to the iphone 4). Is this just a bug somewhere in iOS?
     
  2. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
  3. chupachup macrumors 6502

    Joined:
    Sep 1, 2013
    #3
    Did you update before this started?
     
  4. Xandros thread starter macrumors regular

    Joined:
    Sep 19, 2010
    #4
    Possibly I guess, though the usb to lightning cable I plug the phone into the radio with is the one that came with the iPhone and I only got it a couple of months ago. Though I have used it pretty much solidly since then (usually have to charge the phone twice a day the way I use it).

    I did think perhaps it was the USB port on the radio so I started using the other one on the front (which I don 't tend to use since the cables get in the way of the gear stick). However it did it with that port too.

    ----------

    I suppose so yes. I got the phone at the start of June and it has iOS 7.something on it but was nagging me to update to 7.1.2 after a while so I did eventually. These problems didn't start until after that. However I hadn't used it much in the car up until after updating it as I hadn't got round to hooking it up to my PC to put my music on it (and also my home WiFi).
     
  5. chupachup macrumors 6502

    Joined:
    Sep 1, 2013
    #5
    It's the update then. My iPhone went nuts after an update also. Used to be perfect with the car, then it went nuts after an update. But it got fixed.
     
  6. psac macrumors 6502a

    psac

    Joined:
    Jul 6, 2009
    #6
    In general my phone starting acting wonky going from 6.X to 7. It got a little better with the 7.x updates, but still not how it was back with 6.
     
  7. Xandros thread starter macrumors regular

    Joined:
    Sep 19, 2010
    #7
    It is the car stereo. I dont have to turn the phone on and off afterall, obviously when driving ive been turning the radio on and off but its obviously not resetting because the radio is still powered by the ignition. It just happened while i was waiting outside for someone twice inside of five minutes so i turned off the radio via the ignition key. Left it for ten minutes and tried again and it's working fine and hasn't done it again, yet.
     

Share This Page