8.4 Music App - How do I hide purchased albums that aren't on my phone?

Discussion in 'iOS 8' started by wacky4alanis, Jul 6, 2015.

  1. wacky4alanis macrumors 6502

    Joined:
    Mar 18, 2009
    #1
    I used to share an iTunes account with my son, and I bought a lot of music for him that I don;t keep on my phone. But as of iOS 8.4, the music app on my phone seems to insist on showing those albums. Is there any way to get rid of them? From the main screen (My Music), I clicked on the red "Artists" and unselected the option at the bottom that says "Show iTunes Purchases", but that had no effect. I still see everything I've ever purchased, regardless of whether the album is actually on my phone. I could probably go through and "delete" them all manually, but that would be a lot of work.
     
  2. Blackforge macrumors 6502

    Joined:
    Mar 8, 2008
    #2
    I think it is tied to this: Settings > Music > Disable "iCloud Music Library".

    Not sure if Apple Music needs to be disabled as well.
     
  3. SomethingBlue42 macrumors newbie

    Joined:
    Feb 8, 2011
    Location:
    ATL
    #3
    I'm having the same issue and it's pretty wonky. Music will show the songs I have loaded on my phone and then all of the music I have ever purchased from iTunes greyed out but ONLY every once in awhile. I'll be in the car trying to find a song and suddenly it will look like this

    [​IMG]

    Then usually as soon as I get home it will switch back to only the songs I have on my phone with no greyed out songs. I have "Show iTunes purchases" turned off as well as "Show Apple Music" under Settings>Music. There is no option to Disable "iCloud Music Library" for me under the path that Blackforge provided.

    I thought it might be an issue of being on LTE vs WiFi as the greyed out songs only show up when I'm on LTE but not ALWAYS when I'm on LTE. I can't figure out what's triggering it. Any ideas?
     
  4. jayinla macrumors regular

    Joined:
    Sep 17, 2010
    #4
    This is the biggest problem I am having with the new app. I have purchased hundreds of songs for work purposes from itunes account that I do not want associated with my music housed on my phone. I have it set to not show itunes purchased songs but it has a mind of it's own. More then half the time they are showing. Some of these songs I even re-ripped at another bitrate and I am showing multiple copies of that song. You would think that if there are over half a dozen music apps available that don't have a problem letting the user decide how they're music is shown and sorted that Apple could figure this out. Until then, I'm just going to have to use one of them.
     
  5. wacky4alanis thread starter macrumors 6502

    Joined:
    Mar 18, 2009
    #5
    I don't even have that setting - maybe because Apple Music is disabled.
     
  6. wacky4alanis thread starter macrumors 6502

    Joined:
    Mar 18, 2009
    #6
    My final solution was to simply "delete" every unwanted album from my iPhone. This somehow flags the album as a "hidden purchase" in your iTunes account. I think it can be undone by logging into iTunes on your computer and going into your account summary. I haven't tried undoing it myself, but that's what I read on the web. The biggest problem with this solution is that the songs will be hidden on ALL phones that use the same iTunes account. Fortunately this is not an issue for me, since my son has moved on to his own iTunes account.
     
  7. epb2001 macrumors newbie

    Joined:
    Feb 16, 2008
    #7
    I'm having the exact same issues. Show Apple Music is disabled as well as Show iTunes Purchases, but songs I didn't explicitly add to the phone somehow manage to show up anyway. I've found that if I kill the Music app, they'll disappear for a while, but always manage to show back up. Funny thing is, I don't think they ever actually play if I'm listening to my music on random. I haven't been able to test this yet, but I'm wondering if the problem occurs when I plug my phone into the USB port on my car stereo. Since the car takes over the Music controls, maybe the settings get wonked. Could be way off, but when SomethingBlue24 mentioned having the problem in the car, it got me thinking. I'll try later and report back.
     
  8. wacky4alanis thread starter macrumors 6502

    Joined:
    Mar 18, 2009
    #8
    Try my solution. On your phone, go to each unwanted album, click on the 3 little dots, and select "delete". It's not deleting anything from your phone (they're not on your phone). It is simply telling Apple to hide the fact you've purchased that song from any phones signed into your iTunes account. If a phone actually HAS the song, it will still play. But phones that don't have the song will not show them "in the cloud" any more. It was the only solution that worked for me.
     

Share This Page