99% of the DMG files I download are corrupt!

Discussion in 'Mac Basics and Help' started by brandoncordell, May 14, 2010.

  1. brandoncordell macrumors newbie

    Joined:
    May 12, 2010
    #1
    I'm having an issue that I can't seem to solve. Anytime I download a DMG file on my mbp it can't ever open them! (1 out of the last 50 files I've downloaded has worked. Or at least that's my estimate).

    It doesn't matter whether I'm using Safari or Firefox. Safari has this issue where it will say 'verification failed' and when I try to open the file, it tells me it's still being downloaded. Firefox will tell me everything downloaded fine, but when I try to open it, the system tells me that the data is corrupt, or there was an error -4906 (I think), as well as a few other messages that I have forgotten.

    Not sure if it's related but I'm can't seem to successfully update my machine either.

    By the way I'm running snow leopard 10.6.3.
     
  2. alex.roy macrumors newbie

    Joined:
    Mar 5, 2008
    #2
    im having the same exact issue. my MBP wont upgrade to 10.6.4 because of an error and i can't install any of the DMG files that i have downloaded.

    any update on a fix?
     
  3. mrbash macrumors 6502

    Joined:
    Aug 10, 2008
    #3
    Have you guys tried downloading other large files? Like a 100MB zip file. This may provide a clue to where the problem is.
     
  4. alex.roy macrumors newbie

    Joined:
    Mar 5, 2008
    #4
    things that i have just tried downloading that have worked and not worked:

    Google Chrome: WORKED
    Mozilla Firefox: WORKED
    10.6.4 Updated: FAILED
    Alien Skin Exposure 3 Trial: ~68mb FAILED
    - Plug-In for Photoshop and Lightroom

    so it seems like the really small files, such as the web browsers install, but the bigger programs do not. i tried downloading the Exposure 3 trial again and this time it said "Image Corrupted" instead of "Verification Failed"

    does that strike any potential diagnosis?
     
  5. AuricBlue macrumors newbie

    Joined:
    Jan 3, 2007
    #6
    The above thread talks about the HD possibly going bad or the file structure being corrupted.

    I remember having this problem a few years back and it turned out to be bad RAM. Very odd symptoms. Mac would boot and run apps OK but a few random crashes and CRC checks (like what dmg files do when you mount them) would fail. Had to run Memtest to find the problem. For intel macs see http://www.memtest.org/. For PPC Macs try google :)

    Good luck!
     
  6. chrono1081 macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #7
    My guess is hard drive too.

    To the OP, back up your stuff now to be safe and if you havent already try a disk repair.
     
  7. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #8
    I would try downloading these disk images to another hard drive and then attempt this installation. Though, I don't think that would be a good idea for the 10.6.4 upgrade. :eek: Looking at the linked thread you may have an HD issue so I'd definitely run an HD diagnostic before you do anything too crazy.
     
  8. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #9
    Since there is a test for memory mentioned...

    A check for the HDD is Techtool Pro's smart check if you have it, or try a demo of SMART Utility.app ... either should show the bad sectors and drive errors if you have them.
     

Share This Page