A few issues, (probably my fault)….

Discussion in 'Mac Pro' started by H2SO4, Dec 24, 2016.

  1. H2SO4 macrumors 68040

    Joined:
    Nov 4, 2008
    #1
    Hi all. Wondering if anybody has any pointers.

    So first I’ll explain the ‘my fault’ part of the title. Basically none of these issues occurred before I tried to install a Sapphire RX470. I’m back with the Apple original 5770 now. The 470 worked well when I’d installed the driver which I had to to do every Windows boot but sometimes it prevented me booting to OSX completely, (black screen), especially if I had that and the original 7300GT installed together.

    My set up - 2010 5,1
    I have 3 hard drives currently in my Mac Pro and they are arranged;
    Bay 1 NTFS Formatted 512GB SSD.(Disk 0). MBR Partition map. Win 10.
    Bay 2
    Bay 3
    Bay 4
    PCI 2 1TB SSD. (Disk1). GUID Partition map. OSX 10.12.2
    PCI 3 60GB SSD. (Disk 2). GUID Partition map. OSX 10.8.5

    The Boot manager shows the disks in the following order, (from left to right);
    60 (60GB SSD).
    112 (1TB SSD).
    Windows (512GB SSD).
    Recovery 10.8.5
    Recovery 10.12.1


    Anyhow, my problems;
    Every time after booting into Windows, (using option boot), my usual start up disk 112 is not available and the Mac boots into 10.8 that I have installed on a separate SSD in one of the PCI bays. If I go to the ’Startup disk pane’ it doesn’t show there either. IU cannot bless it within 10.8 and when I boot into the 10.12 recovery to sort it I find that SIP has been switched back on despite me having disabled it so I then turn it off the bless works Ok.
    Also does the Mac have a default boot order? ie if I’d taken two bootable installations from separate machines and inserted the drives and clicked the On button which would the Mac choose to boot if any? Does it go by drive bay/disk name/etc?

    Cheers.
     
  2. slughead macrumors 68040

    slughead

    Joined:
    Apr 28, 2004
    #2
    I might have a similar issue. Since installing Sierra my 5,1 mac pro has been having problems detecting the non-sierra drive (granted, different than your situation), especially windows.

    I'd recommend installing refind:
    https://sourceforge.net/projects/refind/

    Also, make sure your hard drives are appropriately blessed.

    One article said certain USB devices can throw a wrench in the boot process too. I haven't explored this.
     
  3. H2SO4 thread starter macrumors 68040

    Joined:
    Nov 4, 2008
    #3
    Thanks. I remember seeing rEFInd when I was spoofing an OS onto my original 1,1. Do you remember which those certain USB devices were? (I have a Logitech MU0007 mouse, xBox controller, Apple wired keyboard and EyeTV Sat plugged in).
    I believe that the blessing has been carried out correctly.
     

Share This Page