"Access Privileges" error in iTunes

Discussion in 'Mac Apps and Mac App Store' started by VladDracul, Sep 5, 2003.

  1. VladDracul macrumors member

    Jun 25, 2003
    South Beach

    I'm getting a very weird error when I try to import new music into iTunes.

    Basically, our Mac is setup with two user accounst. Since both my wife and I use iTunes, I moved the "iTunes Music" folder to the first level in the directory hierarchy so that we could both shared the same files.

    The problem is that, while I'm able to import CD music just fine, my wife isn't able to do it from her account. When she tries to do so, she gets a "Access Privileges error occurred while converting the file" message. I have given her read and write access to the iTunes Music directory, but the error keeps happening. I even went so far as to make her the owner of this directory and it still doesn't work.

    Has anyone else encountered this problem?
  2. zimv20 macrumors 601


    Jul 18, 2002
    changing access rights on a directory (errr... folder) doesn't automatically change everything beneath it.

    check some things underneath (an actual mp3 and all the folders containing it) and see if that's it.
  3. VladDracul thread starter macrumors member

    Jun 25, 2003
    South Beach
    Well, it's definately not a rights issue with the iTunes Music folder. I have tried moving files to it manually, have successfully created sub-folders, etc. Everything works.

    I'm thinking maybe iTunes uses a caching directory someplace else and maybe the rights problems is just there.

    Also, I just found out she's not able to import new music into the library no matter where it comes from, nevermind importing from CD's.
  4. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
    You probably need to change the permissions on the iTunes Music Library file. This is where it stores all the title info and placement of the songs. Also, it may be trying to import to the Music folder in your home folder, even if you did move the folder. But i suspect the iTunes Music Library file to be the culprit. When you change the permissions to the Music folder, hit the Apply to Enclosed Items button. Also manually inspect the Library file to make sure the changes took.
  5. rdavis macrumors newbie

    Jan 10, 2004
    I had the same problem with my own account, when I looked at the permissions for my iTunes folders, they were set to Read/Write except for all of my individual band music folders underneath 'iTunes Music', these were set to read only. I highlighted all of these and changed the permissions to Read/Write and it let me import stuff again!:confused:

Share This Page