iPhone Adding photos from My Photostream to an album doesn't work with a specific person

maverick28

macrumors 6502
Original poster
Mar 14, 2014
385
249
I tried to add a photo with a specific person (if I didn't misunderstand the "specific person" part of the misbehaviour, of course) from My Photostream to an album containing photos only with that person but failed. It showed the typical Gene effect of the photo collapsing into the album's thumbnails but the photo wasn't there; I did that repeatedly to no avail. I tried other photos with other people to add to the same troubled album or other albums, it worked. However, I still can't add this particular person to its album. I swear it worked in the not-so-distant past.
For some reason "duplicate and edit" in My Photostream didn't do anything either, then for some unidentified reason it got back to a normal order. As the result, I could add the photo with the person in question only via saving to Camera Roll and then adding to that album.
Has anybody faced such discrepancy?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.