Adding powerbook memory - am I missing something?

Discussion in 'Macintosh Computers' started by Westside guy, Feb 17, 2004.

  1. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW

    First I want to apologize for this lengthy post. I just want to be sure I'm relaying all the relevant information I can think of.

    I am running into an odd problem, and thought I'd ask if I'm overlooking something.

    I recently bought a 512MB sodimm for my powerbook. Now in the past when I've added memory to x86 machines (and I've done it a lot), it's usually just a matter of putting in the new dimm and powering the machine on - the BIOS sees the new memory and registers it. On older machines I remember having to go into the BIOS and manually enter the memory size. I have never ever had a problem with bad memory.

    But anyway - so I get this pc2700 sodimm from Crucial, put it in, and turn the machine on. It boots up to the start of the graphical interface, but freezes on a clear blue screen. I power down, boot it back up, and it boots... but freezes during login.

    So I try just this new chip, and run into problems; so I put in just the original 512 and things are fine.

    Okay. Bad RAM. I send it back to Crucial, and they send me a replacement.

    So today I put in the replacement, and run into EXACTLY THE SAME PROBLEMS. Both sodimms in, things eventually freeze. Just the new sodimm in (sitting in the socket that the apple sodimm normally sits in), and it freezes during bootup. So I put the original sodimm back in by itself... and everything is good again.

    Now I've never had trouble with Crucial memory before (in PCs). The sodimm says "PC2700S", which is exactly what the factory installed sodimm says. It just seems odd that I'd get two bad sticks of RAM from them.

    So: Is there some obvious step I am missing? Something I'm supposed to manually reset once I've added the RAM?

    Thanks for any insight you can provide.

    Edit: My powerbook is one of the new 15" 1.25GHz powerbooks, which came with one 512MB stick of RAM installed.
  2. ibookin' macrumors 65816


    Jul 7, 2002
    Los Angeles, CA
    There shouldn't be any extra steps necessary. RAM is just as plug and play in Macs as it is in x86 machines. I added RAM to my PowerBook and I just put it in and it worked.

    Stumps me. Try getting another SO-DIMM from Crucial. While it is unlikely that you get two bad modules, they both could be part of a bad batch that got shipped to them.
  3. cb911 macrumors 601


    Mar 12, 2002
    BrisVegas, Australia
    i recently thought it would be a nice to give my 512MB RAM chip a 1GB chip to sit there on top of it, so i ordered the cheapest i could get (third party) and put it in, nothing. so i took it back to the store and they said it was faulty (also, i got upgraded free to Apple RAM!! :D). the Apple RAM worked fine.

    supposedly there's a whole batch of RAM out there that won't work in the new PB's. Apple changed the RAM specs and didn't tell any of the manufacturers of anything. :rolleyes:

    do a search on the Apple forums.

    good luck sorting that out.
  4. virividox macrumors 601


    Aug 19, 2003
    Manila - Nottingham - Philadelphia - Santa Barbar
    yeah looks like u got 2 duds in a row, bummer. but since its crucial u wont have a problem getting it replaced, but i feel ur annoyance
  5. rtdunham macrumors 6502a


    Jun 21, 2003
    St. Petersburg, FL, Northern KY
    bad memory

    one of the memory mfgrs at macworld expo complained to me that apple had just the day before told them of new specs for one of the computer models they'd been selling ram for for more than a month. so it's easy to imagine being sold the wrong ram.
  6. New Guy macrumors member

    Apr 15, 2002
    This may or may not help but I remember having to reset the RAM in my powerbook a couple of times before I got it to recognize the new chips. Having been the first time installing RAM in my powerbook I wasn't prepared for the amount of force necessary to get it to stick right. I had to go through the process a couple of times, restarting, shutting down, apllying more force each time before I felt it click in.
  7. lazyboy922 macrumors 6502


    Dec 9, 2003
    Las Vegas, NV
    I just installed new ram from crucial as well. my powerbook was acting all messed up. Freezing and what not. So they sent me a replacement and it works fine now. just make sure you have it pushed all the way in the slot. I think maybe that could have been my problem, but i'll never know now, since i returned the chip.
  8. abhishekit macrumors 65816


    Nov 6, 2003
    akron , ohio
    well i added 512 ram module, from crucial, to my ibook. At first it did not recognize it and said the ram was only 128 ram. I found out that although i had placed the ram correctly it wasnt sitting snugly enough. Small thing but do check it once more before you send the ram back.
  9. Groovymalaka macrumors newbie

    Dec 20, 2004
    Join the club of misfortunate PBG4 1,25 owners

    I'm sorry to tell you but you're not the only one experiencing problems withg installing new RAM in their alu powerbooks 1,25.

    Here's a thread from the apple support webpage where you'll find many more angry owners.

    I have the same problem, my powerbook only wants to work with the new RAM when the power adapter is not in. Once I connect the adapter, the machine freezes, and when I restart, it freezes again after a while in the startup sequence.

    Maybe all misfortunate users should participate in the apple forum?
  10. Pilgrims Pro macrumors regular

    Jan 30, 2003
    LOL...did you have to notice this thread is 10 months old. Thanks for the link though, I am getting ready to upgrade to a Powerbook, and will be buying RAM.

Share This Page