After re-booting, my user name has disappeared from login window? It only shows Other

Discussion in 'iMac' started by yyzzpp, Dec 13, 2010.

  1. yyzzpp macrumors newbie

    Joined:
    Aug 24, 2010
    #1
    Ok first of all, I apoligize if this post is in the wrong section.

    Ok so today my 27" iMac (10.6.2) was acting kind of weird. In safari and chrome webpages would spontaniously crash for no reason (on my macbook, the same webpages were fine). So, to try and fix this issue, I decided to restart my imac. After all the applications quit, I was left with a blank screen with my wallpaper. It stayed like this for several minutes, so I decided to just hold the power button to force the imac to turn off. When I turned it back on, my user name was not displayed in the login window:confused:. All there was for accounts was "other" and a network symbol. When I click other and entered my user name and password, it did not work. I am sure I was using the correct password and username. I also tried: username: root, but that also did not work. So i rebooted again and the same "other" still was there without my real account. So i booted into my Mac OS X install dvd and I repaired the disk and all the permissions (there were a lot of things to repair). I thought that this would solve the problem, but it did not. As well, I tried booting in safe mode, no luck.:confused:
    I have also reset the PRAM, but still no luck.
    I have done some google searching and I can't really find a solution. So I hope someone here can help me :)

    Thanks in advance
     
  2. MacHamster68 macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #2
    you could try that first , update your system from 10.6.2 to 10.6.5 ;)

    to do so just click on the black little apple in the left top corner and in the menu that appears click software update ,it then will tell you what updates are there to be installed , do it as often until it tells you that there are no more updates available
     
  3. loayza macrumors newbie

    Joined:
    Dec 16, 2010
    #3
    I found a solution

    Something similar happened to me today, although I had the system up to date. I still have no idea of what caused my problem, very very weird, but I could solve it.

    This is what you should do:

    1.- Boot your mac with your OS X current version CD/DVD (Press C during boot to do so)
    2.- Select your language and continue.
    3.- Choose the option "change users password" (or something like that) in the menubar.
    4.- There you will discover that your old user/s don't exist anymore :confused: So what you shall do is to set a password for the root user.
    5.- When you have finished, quit and restart the mac as normal.
    6.- Login with root user and the password you've just set.
    7.- Once inside the system go to system preferences -> users.
    8.- There you will check again that your old user/s don't exist anymore.
    9.- Create a new temp user (name it as you want, what different of your previous user/s)
    10.- Once created change its user name and it's default folder with the original user name and the original user folder (that already exist with all your info)
    11.- Reboot.
    12.- Your user should exist again and everything should be as expected.

    Obviously in step 9 you could instead create directly the user with the same original name. I haven't tried that, but for some reason I prefer to create a temporary one just in case creating a new user with the same old name could remove old preferences or info.

    Important: If you had more than one users create the new temporary users in the same order of they were created the old ones (same UIDs). That will avoid annoying permissions problems.
     

Share This Page