After updating to 10.12.3 Mail search gives zero results

Discussion in 'macOS Sierra (10.12)' started by Nemesis19, Jan 31, 2017.

  1. Nemesis19 macrumors member

    Nemesis19

    Joined:
    Mar 21, 2010
    #1
    Since I upgraded to Sierra 10.12.3 the Mail.app search function doesn't work anymore.

    I have 8 email accounts and when I type something in the search field in Mail.app I get nothing.

    Funny thing, I can view the emails from Spotlight. So my suspect is about a bug on the app.

    I tried to:
    - reinstall the combo update 10.12.3
    - delete all envelope files in Mail library to reset the indexing of the mailboxes
    - I rebuilt the mailboxes
    - removed mail from spotlight from system prefs to re-enable later
    - deleted all the accounts to reinsert again
    - reset completely mail app to reconfigure from scratch

    I miss only to reinstall the entire OS, but since it's painful...I wanna ask if anyone has the same problem.

    I'm on a MacBook Pro 15" 2016.

    My girlfriend has the same model but 13" and she has no issue.
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    Try adding the entire Macintosh HD to Privacy. Wait a bit then remove.
    Open Activity Monitor in Applications/Utilities.
    Enter md in the top right search filter.
    You should see many mdworker files. Are they active?
    If no, the boot into Recovery drive and use Disk Utility to run First Aid on your Macintosh HD.

    Boot into the Recovery Drive by holding down Command R when restarting.

    Note: you can reinstall macOS over itself and that might help if the above steps does not kick start Spotlight.
     
  3. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    Doing a "re-index" as described by dianeoforegon worked for me when I upgraded to Sierra and my email search stopped working.
     
  4. Nemesis19 thread starter macrumors member

    Nemesis19

    Joined:
    Mar 21, 2010
    #4
    I tried everything. I forgot to mention that I also did the "Try adding the entire Macintosh HD to Privacy. Wait a bit then remove.".

    Reinstalling Sierra solved the problem.

    Many thanks!
     

Share This Page