after updating to 5.1.1 my music won't sync

Discussion in 'iPhone Tips, Help and Troubleshooting' started by gnychis, May 28, 2012.

  1. gnychis macrumors 6502

    Joined:
    May 24, 2009
    #1
    I recently updated to 5.1.1 from 5.0.1, and after doing so none of my music would play on my phone. I would go to play a song, and the music app would show the song starting, but the audio would never start and the song would never advance. I tried restarting the phone, and no matter what I couldn't get music to play.

    So then I decided to do a restore of my phone and let it resync the music and try again. After doing the restore, my phone will absolutely not sync any of my music. I have tried checking and unchecking "Sync only selected songs and videos." No matter what it is set to, I cannot get it to sync any music. It syncs my apps, and then just finishes the sync without copying any music over.

    My music files are valid, I can play all of the music directly in iTunes.

    I never had this issue before upgrading to 5.1.1. I also have iTunes match. So, my whole library still shows up but everything is over match. I am able to play music now over match, but I would still like part of my library to reside directly on the phone.
     
  2. gnychis thread starter macrumors 6502

    Joined:
    May 24, 2009
    #2
    apparently this has all to do with iTunes match:

    http://www.macworld.com/article/1163607/toggle_between_itunes_match_and_local_syncing.html

    After you enable iTunes match, it won't sync any music locally to the phone. This sucks, as there is a certain amount of music I don't want to have to download to listen to. As the article says, you can get around this by disabling Match on the phone, sync'ing, and then re-enabling match. This worked for me.
     

Share This Page