After upgrading to leopard, I can't connect to any wifi networks at all! HELP!!! :(

Discussion in 'Mac Basics and Help' started by motulist, Jan 26, 2008.

  1. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #1
    When I was on OS 10.3, there were several open wifi networks that I connected to all the time, but since upgrading my 2 different powerbooks to leopard, neither can connect!

    I've heard lots of people in other threads griping about leopard's airport being very flaky, saying it'll connect but then constantly drop the connection every few minutes, but I can connect at all! Am I the only one who can't get their airport to connect to an open wireless connection at all in the first place?

    In 10.3 I'd connect by just setting my network preferences to "Automatic" and then just selecting the network name from the airport menu bar item. But now in leopard 10.4 I can't connect at all no matter what I try!

    I turn on airport, select the name of the network, the airport indicator shows full bars and the name of the network is checked, but network prefs says "Airport does not have an IP address and cannot connect to the internet. When I go to the advanced settings > TCP/IP, configure IPv4 is set to "Using DHCP" like it did in 10.3, but it has no IP address listed there. So I hit "Renew DHCP Lease" to get a new IP address like I used to in 10.3 when it lost the connection, but now it won't give me a new address, it just dims out the button for a second like it's trying to request a new IP address, but then the buttons undims a second later the IP address area is still left blank.

    And on a different open network I used fine under 10.3, now when I select it in the airport menu bar list, it won't even get selected.

    HELP!!!
     
  2. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #2
    you can try this...

    Instead of automatic use a secondary account, you should have checked the following:'ask to join new networks', also in the advanced button, have checked the following: 'disconnect from router when logging off' and 'remember any networks this computer has joined' in the preferred networks list delete all except yours. under the TCP/IP tab in the DHCP client ID list is your own IPv4 address. turn ipv6 off. in the DNS tab input your router's IP address and the DNS numbers provided by your ISP, then apply. now you need to go to your wireless router and have the following settings: mixed mode and one channel instead of automatic, in the MAC filtering input your IP address or you airport ID, in Terminal type the following: sudo ipfw flush. see if that begins to help.
     
  3. BioChron macrumors regular

    BioChron

    Joined:
    Jun 13, 2006
    Location:
    Alaska
    #4
    Since I installed Leopard on my PowerBook and iMac, both don't get the full WiFi connection. I'm not sure as to why. I hope you figure out your problem!
     
  4. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #5
    if...

    if your connection is lagging, the input the DNS numbers in your DNS tab in the network pane, the numbers I mean are the ones showing in your router's stat page.
     
  5. motulist thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #6
    But this isn't my personal network, these are open public networks. So I can't get any of that info and I can't change any settings besides the settings on my computer.


    Do you mean a new "Location" account in the Network system pref pane? If so, then I've done it.

    Done

    Done

    I can't do any of that because it's not my network, it's a public network.



    -----


    I've skimmed those, but as I stated in my original post, my problem is entirely different than the one that people have been talking about constantly in other threads. Everyone else is complaining that their wifi is dropping connection after some period of time. My problem is that I can't connect to any wifi networks at all in the first place, which is a totally different problem.

    It happened on both of the 2 different model powerbooks I'm in charge of (mine and my Mom's). It happened right after I upgraded each to leopard, which were separated by a few days. I'd be able to connect with the tiger installed one, but not the leopard installed one. Then when I upgraded the second one to leopard also, it had the exact same inability to connect to any wifi network at all.


    *** Important note: this was done on a complete erase and clean install of OS X with no data or info migration at all. So this system and user account is pristine.

    ---

    I followed the instructions in that other thread you link to, but it's still a no go.

    My firewall is set to allow all incoming connections

    My IPFW lists "65535 allow ip from any to any"

    This is an open public network, so there is no password for Keychain to mess up
     
  6. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #7
    I went to miami...

    and since my folks do not have internet access, I was able to get a signal from a nearby network, and I experienced something similar to what you have described. except that it did provide me with a self-assigned ip address but no router ip address, so I did have 3 bars but no connection. after tinkering I almost gave up, I made a new location in network settings and after a good while the router's ip address showed up and I was able to connect to the internet on this open network, at least in Tiger/Panther it was very fast. I had firewall off just in case. I usually dont connect to other networks so my experience is very little. I can tell you I spent a good 20 minutes setting it up, I dont know how far the signal was but it was a decent speed for just two bars when i did manage to connect and I can see why its so distracting for something that should only take a minute or so. I cant remember the steps but I did mess around with the network settings until something appeared, I wish I could only remember so it could be reproduced, but its an indication that connecting to various networks is still not a "snap" in Leopard. If I do remember Ill post it.
     
  7. Mlobo01 macrumors 6502

    Joined:
    Jan 23, 2003
    Location:
    Weehawken New Jersey
    #8
    the network dropped after the upgrade...

    I had to delete all the plist files because it did not re-connect after I awoke the computer from sleep, so I threw away the system configuration folder, all airport plists files and the keychain, upon restarting the keychain showed the files I was looking for which is the systemUIserver and the airport deamon, (in the keychain lists as: airport) I added the System prefs and the apple80211agent. I think this stabilizes yet again the network.
    your keychain should look like this:
     

    Attached Files:

    • one.jpg
      one.jpg
      File size:
      31.8 KB
      Views:
      67

Share This Page