Age of Empires III and Age of Mythology connection problems

Discussion in 'Mac and PC Games' started by Cloudsurfer, May 26, 2008.

  1. Cloudsurfer macrumors 65816

    Cloudsurfer

    Joined:
    Apr 12, 2007
    Location:
    Netherlands
    #1
    It worked fine before, but now for some reason the games just won't Join a LAN game. I'm running Leopard 10.5.2 and I have installed the latest patches for both games (1.0.3 for AoEIII and 2.0.1 for AoM). It's possibly worth noting that GameRanger says I'm "behind a Port-Restricted Cone NAT Router" (although GR is online and I just want to play LAN).

    In Age of Empires III, it simply says "Failed to Join Game" and in Age of Mythology, there's a countdown screen that says something similair when the countdown is completed.

    I'm puzzled. I've tried every possible setting in System Preferences and on my AirPort Extreme, nothing works. Is this a common problem? Anyone know what I can do?
     
  2. Groberts macrumors newbie

    Joined:
    Jul 9, 2008
    #2
    same problem here

    I'm having all the same issues. It just started this week. I played a LAN game fine just last week with someone using Tiger. Tried Gameranger as well and it didn't work either, couldn't join a game.

    Anyone have any idea's?
     
  3. iriejedi macrumors 6502a

    iriejedi

    Joined:
    Oct 4, 2000
    Location:
    Nor Cal
    #3
    Router?

    My experience with these games and most recently CnC3 is that is you have a router... it is nearly impossible to figure out. Try plugging the Mac directly into modem. (I know this does not help LAN) but this will at least verify the MP possibility of the set up.

    You would think OS X.5 and a Airport Extreme could figure it out.... I've tried all the port forwarding tip web sites and emails and nothing works...

    on CnC3 I can join games, chat in the wait room.. but no one can see 'me'.... so the game can't start....

    But the direct modem to Mac route solves this - AOE3 is the same.

    Good luck.





     
  4. StrawberryJam8 macrumors newbie

    Joined:
    Jul 15, 2008
    Location:
    Nevada
    #4
    Hmmm

    It could be a router problem, a firewall problem or even an incompatible software patch problem. Check out your firewall and network settings.
     
  5. nasca420 macrumors newbie

    Joined:
    Jul 28, 2009
    #5
    Lose connection ten minutes in

    After about ten minutes of play, or after some fighting an unresponsive player message appears for all other players in the game. After it times out I'm given the victory, but I don't know why it's doing that. I have a high speed internet connection, and i think I'm losing the connection with gameranger. Does anyone have any ideas?
     
  6. Donaldduck08 macrumors newbie

    Joined:
    Oct 10, 2010
    #6
    I have the exact same problem! Im using version 1.05 of age of empires 3.
    Does anyone know how to solve this?
     

Share This Page