Age of empires III freezes on new macbook pro 2.5 gig

Discussion in 'Mac and PC Games' started by padré, Apr 2, 2008.

  1. padré macrumors regular

    Joined:
    Aug 7, 2006
    #1
    hy guys

    I just bought a new macbook pro 2.5 gig 512 vram with an aditional 2 gig ram (making the total 4 gigs of ram)

    I was playing the mac version of age of empires 3 and it totally freezes forcing me to reboot the computer?

    any body knows how to solve this problem cause happens time and time again

    (in bootcamp i was playing oblivion wich went great although the last time i tried i got the blue screen of death after wich the computer rebooted)

    any help would be great :)
     
  2. student_trap macrumors 68000

    student_trap

    Joined:
    Mar 14, 2005
    Location:
    'Ol Smokey, UK
    #2
    simple solution, you need to download the latest patch, then it'll run great!

    http://www.apple.com/downloads/macosx/games/demos_updates/ageofempiresiii.html

    :)
     
  3. Beric macrumors 68020

    Beric

    Joined:
    Jan 22, 2008
    Location:
    Bay Area
    #3
    No clue what you're talking about; I run it on a September 2007 MACBOOK with no problems. :p It barely fits the specs, but I don't play the AoE series for graphics. Or I've got an iMac for the maxed out graphics settings.

    Like the previous poster said, download the update. If that doesn't help, do a fresh reinstall of AoE3. I did that when I was getting a CRC error despite having all the correct updates installed.
     
  4. aoegirl macrumors newbie

    Joined:
    Jul 28, 2008
    #4
    The same thing is happening to me. It is usually late in the game when there is an attack with lots of units on screen so the system has to work hard.

    Most of my graphics settings are on low or are not on, but given the computer I have -- I have the 2.6GHz Intel Core 2 Duo processor, 4gbs memory, and 7200 rpm hard drive -- one would think I shouldn't have to do this. I have also updated the operating system software for leopard to the latest edition and have uploaded the latest AOE patch and it is still happening. I am playing single player sqirmishes so I am not playing on line.

    Saving the same frequently is both annoying and does not work. Often it simply refreezes when you retrive the saved game or, even if it allows you to finish the game, it does not provide you with additional cards even when it indicates that you have advanced some levels and are entitled to new cards.

    I do not know if the problem is leopard, the video card since others don't seem to be having the problem.

    I noticed that generally, when it froze, the music continued to play. I, therefore, turned off the music to see if that would fix the problem -- after 2 games, it has not frozen again, but I was running at a 60% freeze rate previously, so it may be too early to tell.

    Anyone else have any suggestions?
     
  5. torombolo macrumors newbie

    Joined:
    Jan 2, 2010
    #5
    AOE Problems

    Hi, I have the same problem. Did you solve it?

    Thanks
     
  6. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #6
    If you just bought your Mac, you can probably call Apple support and ask why this game is freezing your Mac. I'm not quite sure though.
    Changing the graphic settings to low, turning off vsync / AA, might help if the error still happens.

    But I do know something that I'm sure will help, run the game in windowed mode. I've had my Mac Pro freeze when playing Horde of Orcs.
    I'm pretty sure if running in windowed mode fixes it for you, it's a flaw with the game.
     
  7. Sweep'n Streets macrumors member

    Joined:
    Apr 22, 2008
    #7
    That's a dead giveaway -- your video card is overheating.
     
  8. cjacks68 macrumors regular

    cjacks68

    Joined:
    May 27, 2009
    #8
    Do you have the graphics option set to "better performance" under the power options? You'll need this option on to use the 9600 graphics card with the 512mb of vram.
     

Share This Page