Age of Mythology Problem in Tiger

Discussion in 'Games' started by velocityg4, May 2, 2005.

  1. velocityg4 macrumors 601


    Dec 19, 2004
    I just installed Tiger in my Roomates G5 and Age of Mythology will not function properly. The error that is occuring is that all units are invisible. They are still there and can be moved but all that is visible is terrain. No units, buildings, trees, etc just grass.

    For a brief background it is a dual 2.0 G5 rev. B and 5200 card. I performed a clean install of Tiger and AOM. I also installed the latest AoM update. Now I have tried running AoM with and without the update and have reinstalled it several times. I have also tried installing from my AoM CD instead of his but it still will not work. Though AoM runs perfectly on my PM G4.

    Does anyone know what could cause this problem? Does anyone have AoM working on a Tiger machine that utilizes core image (just in case core image is the culprit)?

    I'm going to try repairing disk permissions and copying the game files over the network to see if that works.
  2. pgc6000 macrumors 6502a

    Jul 12, 2004
    Weren't their other complaints about games not running under tiger? I hope Tiger doesn't keep this up.
  3. parrothead macrumors 6502a


    Sep 24, 2003
    Edmonds, WA
    I heard it might have something to do with the ATI cards. I saw an update for them on VT a few days back, but I don't have Tiger yet so I didn't update my driver.

Share This Page