Ah. Crap. I'm in a tight spot!

Discussion in 'General Mac Discussion' started by Ryvius, Sep 28, 2004.

  1. Ryvius macrumors member

    May 4, 2004
    I've never had any tech problems at all with my macs. But my Powerbook today started acting all strange. First it was saying that the keychain Safari used was no longer valid. Then ITunes's library was suddenly corrupted. I recompiled my MP3s but everytime I restart the program it gets corrupted again.

    I tried reinstalled Itunes by downloading it but according to Safari the files couldn't be verified upon completion. When I tried mounting the drive/installing the program it gave a corresponding error message.

    I used First Aid to fix the registry. All my system files are updated from Apple's update program.

    What could be wrong? Anyone have any ideas or suggestion on how to fix Safari and Itunes?

    Mucho gracias,
  2. earthtoandy macrumors 6502

    Jan 18, 2003
  3. t300 macrumors 6502a


    Apr 10, 2004
    Try repairing permissions, zap the PRAM, etc., restart, then get back to us. Good luck!
  4. Diatribe macrumors 601


    Jan 8, 2004
    Back in the motherland
    And now we even have a GUIDE for this. :D

    Edit: Damn you Ede :p Beaten to it
  5. Ryvius thread starter macrumors member

    May 4, 2004
    Followed that guide to the letter. Zapped the PRAM, used the Disk Utility, and ran fsck. No errors detected on the latter.

    I still get "Keychain Not Found" when running Safari elaborating that "Keychain 'login' cannot be found to store "Safari." Gives me Cancel and Reset to Defaults as options. No matter which one I choose the exact same message comes up next time I load Safari.

    On Itunes, it says: "The file "iTunes 4 Music Library" does not appear to be a valid music library file. iTunes has created a new music library and renamed this file to "iTunes 4 Music Library (Damaged) 9".

    So I hae to readd all of my music everytime I load Itunes. :((

    Nothing appears to be working, should I reformat the computer? I've never encountered anything like this. Not it seems every document I load up in MS Office is corrupted. The more I use the computer the more things appear to be busted.
  6. WinterMute Moderator emeritus


    Jan 19, 2003
    London, England
    Get everything you can't replace off that drive as quick as possible without opening ANYTHING, then zero the HD and re-install the OS, then check your iTunes registry problem, if it still persists you have what sounds like a fatal hard drive problem and you'll need a new drive.

    Have you tried Diskwarrior?
  7. Elan0204 macrumors 65816


    Apr 16, 2002
    Chicago, IL
    Just in case your hard drive is dying, make a back up of all critical data NOW. The more you use a dying hard drive, the closer it gets to death, so try to back things up while there is still hope.

    After that, boot from the Apple Hardware Test CD, and see what it says about your computer. You could also try booting from the OS X install CD and using disk utility to run first aid on your hard drive.

    Assuming all your hardware turns out to be OK, then you may just need to do a clean install of OS X.
  8. Ryvius thread starter macrumors member

    May 4, 2004
    Dang, I'm on it. Thanks for the info, I'll shut this machine down and transfer all critical files over to my other computer asap and proceed from there.

    Hope Apple's tech support team won't give me too much hassle if worst comes to worst.
  9. Elan0204 macrumors 65816


    Apr 16, 2002
    Chicago, IL
    If you are still under your 1 year warranty, or covered by the extended AppleCare warranty, you should have no problem getting the service you need. If you have an Apple Store near you, you may also go see a Mac Genius and see what they say about your problem.
  10. Flynnstone macrumors 65816


    Feb 25, 2003
    Cold beer land
    This may be related.
    I just had an iBook with strange problems. It appeared OK, but we where going to upgrade it to Panther. I used Dantz Retrospect as a backup client. It would get part way through then die. Then I tried connecting with another machine via ethernet. It would get part way through , then the iBook would kernel panic. Consistently! I thought very strange. So then I connected the iBook to the other machine in target disk mode (firewire disk). I tried to copy, but would get strange errors.
    Finally I pulled out my DiskWarror disk, upgraded it to 3.0.2. It found "overlapping files" and I think overlapping directories. I'd never seen this before. It tried to fix the errors but never did. It failed grace fully though.
    I eventually manually managed to copy files across.
    And I reformated the drive and installed Panther. Everything is good now.
    I did get a email from Alsoft on what to do. Look at the detailed list of overlapped files a manually delete some and retry. But if they are system files, a re-install of the OS is necessary. What I did any way.

  11. mcs37 macrumors regular


    Mar 2, 2003
    Washington, DC
    Liked the reference to Oh Brother Where Art Thou?

Share This Page