airplay not working

mannock

macrumors newbie
Original poster
Dec 23, 2015
2
0
not sure if this is really an ipad problem, but I am trying to mirror my ipad 2 display to apple tv ( I think this is version 2 as it's black with a silver remote) the apple tv seems to work ok and airplay is on, and both devices are connected to the same internet hub with a good signal, but there is no airplay icon on the ipad and they don't seem to be connecting to each other. Everything is right up to date software wise. according to the manuals it should work automatically.
 

satcomer

macrumors 604
Feb 19, 2008
6,978
1,183
The Finger Lakes Region
not sure if this is really an ipad problem, but I am trying to mirror my ipad 2 display to apple tv ( I think this is version 2 as it's black with a silver remote) the apple tv seems to work ok and airplay is on, and both devices are connected to the same internet hub with a good signal, but there is no airplay icon on the ipad and they don't seem to be connecting to each other. Everything is right up to date software wise. according to the manuals it should work automatically.
Reboot the Apple TV. There seems a cache issue in software!
 

satcomer

macrumors 604
Feb 19, 2008
6,978
1,183
The Finger Lakes Region
I also heard a while ago if you turn OFF IPv6 in your device settings then AirPlay wouldn't work! The poster said on his Mac his AirPlay to his Gen 3 he had to set his Mac Network settings IPv6 to 'Automatic' to get AirPlay working!
 

waw74

macrumors 68040
May 27, 2008
3,562
359
if nothing else has worked, try rebooting your router.

or google "airplay + your router's model" and see what comes up, there might be settings that you can change.
 

Hermes Monster

macrumors 65816
May 4, 2010
1,146
310
UK
not sure if this is really an ipad problem, but I am trying to mirror my ipad 2 display to apple tv ( I think this is version 2 as it's black with a silver remote) the apple tv seems to work ok and airplay is on, and both devices are connected to the same internet hub with a good signal, but there is no airplay icon on the ipad and they don't seem to be connecting to each other. Everything is right up to date software wise. according to the manuals it should work automatically.
Did you get this working? One thing worth checking, is whether your router has a 2.4ghz signal AND a 5 ghz signal. Though both devices are connected to the same hub they may be on different bands and therefore can't see each other
 

mannock

macrumors newbie
Original poster
Dec 23, 2015
2
0
Did you get this working? One thing worth checking, is whether your router has a 2.4ghz signal AND a 5 ghz signal. Though both devices are connected to the same hub they may be on different bands and therefore can't see each other
[doublepost=1460840596][/doublepost]thanks HM sorry for the delay in my reply, I checked and found that one device was on the 2.4g band and the other on 5g band but that wasn't actually the problem. What I had not realised was that I had not been shutting the apple tv right down, just putting it to sleep, in fact I don't think there is an option for switching it off completely. Anyway, after you suggested rebooting it I pulled the power cord out for a few seconds and on starting it again found that the ipad airplay icon suddenly appeared for the first time. I was able to see my ipad mirrored on my tv at last. Ended badly though, my BT sport app informed me that it was not able to support mirroring so I gave up at that point as the whole object was to watch motogp. Seems like I will have to buy BT vision or BT TV or just carry on using the app on my pc.
 

mckq

macrumors newbie
Jan 22, 2016
2
0
Just to note I now stream to AppleTV4 from our iMac using "mirror screen" function on airplay (used with Air Mouse app on iPhone a reasonable workaround for non-streaming iOS apps) and occasionally the Airplay icon on the iMac disappears. I read on another forum that toggling WiFi off/on can restore the Airplay icon and have had good luck with that approach.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.