Airport and Windows XP

Discussion in 'Macintosh Computers' started by WillVmk, Aug 18, 2003.

  1. WillVmk macrumors newbie

    Aug 18, 2003
    Hi, I'm a mac user for several years, and at home we are running an Airport Base Station ( but not the extreme, the first one) with 4 mac's . Now we have one Dell with a TrueMobile wireless card in it, and it can see the base station but cannot connect to it, even with a valid WEP password.
    I was wondering how I can make it work? or is it impossible to connect an Windows Xp PC to a Apple Base Station?

    THx in advance,

    BTW: I'm still a mac user, a very hard one even.
  2. mkaake macrumors 65816

    Apr 10, 2003
    i'm pretty sure i read about this once...

    try turning off all encryption and see if you can connect. i just seem to remember that being the problem of this author of an article...

  3. legion macrumors 6502a

    Jul 31, 2003
    I'm laughing so hard right now because I just solved the exact problem you're facing after two weeks of trying to come up with something.

    Here's the deal with Airport. It uses a static open WEP key that appears to be a normal ASCII word, but the kicker is it's not. It actually gets hashed into hex by the Airport and transmits that as the key. Now other airport cards have no issue with this (because they take the passphrase you enter and do the exact same hex translation before responding to the base station's challenge) but any other maker's wireless card will have problems because you can't enter the passphrase-- you need the hex key. To get the hex key, go to the admin utility for the airport base station and click on the padlock. It will give you the hex key translation that it's using for the passphrase. Type that in as your key on your Dell and it'll be able to connect. (remember 40-bit key in Apple is usually referred to as a 64bit key by everyone else and that you want to enter a hex key and not an ASCII key in XP (it'll be exactly 10 symbols of 0-9 or a-f) If you are using 128bit, it'll be longer.) Good luck.
  4. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    Legion has is exactly right. I had the same problem when I put my Tivo on the network with a Linksys adaptor.
  5. WillVmk thread starter macrumors newbie

    Aug 18, 2003
    I have the WEP-key : 85558864d6 , but it still doesn'twork..
    So this is what I have
    I have an old base station configured with 4 mac's and e Dell, on that Dell I have a TrueMobile Wireless 1150 network card. When I start my dell, I get a wireless connection visible but I can;t use the internet through it.
    Thx for the quick help guys.
  6. rueyeet macrumors 65816


    Jun 10, 2003
    Okay, I and another friend of mine are having the exact same problem--trying to add a Win XP machine to an Airport network, and the Win machine sees the base station but will not connect to the network--and we've both already done the WEP hex key thing.

    Any other tips? This is driving me nuts; I really do want to share my DSL with my housemate via AirPort, and my friend would really like his wife's Win XP laptop to be able to access their cable connection, but we and my housemate's brother have all pounded on this to no avail. I don't think my friend and his wife are even using WEP encryption.

    Here's my setup: My Snow Airport base station is plugged directly into the Verizon-supplied DSL modem. The base station is using 40-bit WEP encryption and is set up not to broadcast the network name, and the AirPort base station insists on distributing IP addresses in order to use the PPPoE DSL connection. My housemate's XP laptop has been supplied with the hex WEP kay and the network name, so that it should auto-connect to the base station.

    What's happening: The wireless connection to the base station is seen by the XP machine, but the AirPort network is not listed in Available Networks, nor is the XP box actually communicating with the base station.

    Can anyone help???
  7. rhpenguin macrumors 6502a


    Jun 10, 2003
    London, Ontario
    lol.. the Airport basestation is rejecting the inferior product... that just makes my day :p
  8. legion macrumors 6502a

    Jul 31, 2003
    we'll fix this, no problem

    Since I wouldn't wish this on anyone else, I'm determined to get this working for both of you....


    Which base station is it? Graphite, Snow? Have you updated the firmware from Apple's site? (This solved a few issues) Do you have Shared or Open WEP keys setup on the Base Station? (Make sure it's Open first and then once we've got that working, you can set it to Shared) The fact that the Dell sees the station means it's strictly a WEP issue. Are you using XP's wireless handling or a proprietary Dell wireless handler? (If it's a Dell handler, later on down the road I'm probably going to bug you with more questions) Could you go into the Dell's driver setup for the wireless card and post all the driver settings? (since it's a dual-band card, it may be trying to force different standards than the Airport can transmit--you'll want to set settings as flexible as possible ("auto" or "and" settings)) Finally, have you tried disabling WEP security on the base station and checked if the Dell can hook-up? (we might as well start there) I'm going to go search for what chipset Dell uses on their card because each of the 2 major ones have their own WEP key quirks....


    Same as above on some of the questions.. have you updated firmware from Apple; have you tried stepping through "no WEP key" and then to "open WEP key" and then onto (if you want) "shared WEP key"? Which wireless cards are the laptops using (make/model)? Have you tried unhooking the DSL line and tried to see if you can get the Macs to see the XP laptop and vice-versa (using Samba if necessary)? What are the driver settings on the laptops' wireless cards? Since you need to have the IP distributed to the laptop, make sure DHCP is set to active.

    Oh yeah, for both, do you have only one key (since there are 4 available) and is the respective key the one that is being set on the laptops?


    I realize what you posted was probably in jest, but the Airport basestation is actually the same as the Orinoco platform customized to Apple's idiosyncrasies (as in, Apple doesn't make the insides and in this case is just making interoperability more difficult when they could have left the platform alone.)
  9. legion macrumors 6502a

    Jul 31, 2003
    Covered in a previous post, but saw this out on the web...

    For WillVmk

    WEB [sic] encryption works with Dell TrueMobile 1150

    April 24, 2001
    Jim Hines

    You can report to your readers that WEP encryption works with the Dell TrueMobile 1150.

    Thanks to Rus Maxham's April 16th report I took a chance at ruining my working wireless network and utilized the network equivalent password in the Airport 1.3 administration utility (Menu/toolbar).

    Checked the enable WEP encryption check box, applied a new password, reestablished my connection to the network via the airport control panel, set the network equivalent password in the Dell TrueMobile Client Manager and it was done. It took me longer to type this letter.

    There are those who say WEP encryption is tantamount to a placebo but hey, it's my placebo.

    More on using the Dell TrueMobile 1150

    September 4, 2001
    Lance Lichtor

    I thought I would share my final success in getting a Dell Latitude [notebook] with TrueMobile 1150 (Windows 2000) to link up to the Internet using an Airport Base Station. Before I go on, the person at Dell with whom I spoke said that this could not be done. Nonetheless, I finally found the MacWindows Cross-platform AirPort special report page, and knew there was some hope.

    Based on what was in this article, I disabled encryption on the Mac side (although I did set up a closed network). When I did this, on the PC side, I saw that there was a radio connection, but I could not get my browser to connect to the Internet. Finally, when I selected start->settings->network and dialup connections->local area connection-> and then double clicked on Internet Protocol (TCP/IP), and selected "obtain an IP address automatically" and "obtain DNS server address automatically", voilà
  10. WillVmk thread starter macrumors newbie

    Aug 18, 2003
    Thx for helping me --

    ok, I'm on the oldest one, guess that's graphite. With only one modem and one ethernet port.
    I have a DSL so i connect trough the ethernet port.
    I have a software called Client Manager for my dell truemobile card and it sees the base station perfectly. Even with WEP encryption off, the PC sees the base station. Ok, one more thing, i connect with my pc through a networkbridge, is that normal?
    under the properties of the connection, what should I do for verification?
  11. tazo macrumors 68040


    Apr 6, 2003
    Pacific Northwest, Seattle, WA actually
    Its a wireless card, not a liver :D
  12. WillVmk thread starter macrumors newbie

    Aug 18, 2003
    This thing is killing me... I have checked everything.. the WEP password, is fine, I installed the newest firmware for my Truemobile card, I installed a the latest version for my base station graphite...
    I see the base station on my dell, and have an excellent radio signal ( can see that in the client manager) .. I have 2 connections : the Wireless and then the network bridge.. everything is working.. except that I can't connect to the internet.
    this is a thing: I have configured my MAC-adress in my base station and I even di the MAC-adress of the network bridge.. is that okay?
    I cannot see where the problem is...

  13. caveman_uk Guest


    Feb 17, 2003
    Hitchin, Herts, UK
    I had a problem setting it up using an airport card and a Netgear base station. First off turn off WEP and MAC address restrictions you may have set up. Does it work? If not hmmm...dunno. Is it just the internet you can't reach. Try pinging a local machine. What's the output of 'ifconfig -a'? Is it what you expect? Is DHCP working (if you're using it)?

    If it does work unencrypted then it's the WEP key or it's format. I found that I couldn't enter my ASCII passphrase and expect it to work with the airport card because as mentioned previously the mac software and my access point treat the passphrase in different ways. Ensure both the base station and the card are using the same encryption method (I use 128-bit). Try entering the WEP key in Hex only - exactly as the base station tells you it is.

    Other than that I can't help you....
  14. rueyeet macrumors 65816


    Jun 10, 2003
    Re: we'll fix this, no problem

    I have the latest firmware from Apple that I'm aware of; everything lately has been for the Extreme base station. Since the point is that I'd like to be able to use WEP encryption, I haven't tried turning it off yet--but yes, that's a valid test. I also haven't tried getting the computers to see each other, since I have no need to share files--but maybe the DSL is the problem. Driver settings on her card (an Orinoco Silver I bought to try and use with the TiBook with the open source drivers) are set in XP, but yes, it's set up to recieve the IP address through DCHP, and the hex WEP key has been entered. I used the key that clicking on the "Password" icon in the AirPort Base Station Admin Utility gives me.

    I'll check Software Update, attempt connecting without WEP, attempt connecting sans DSL, and possibly check trying a quoted WEP key, and let you know what gives.
  15. nickalopogus macrumors newbie

    Oct 13, 2003
    Encryption problem

    I'm having the same problem connecting my Toshiba TE2300 (Windows XP, Internal Wifi Card, Airport Extreme Admin Utility V3.1) to my Airport Xtreme Base Station (snow, firmware 5.1.3).

    The problem connecting is only with encryption enabled (ie WEP). Unencrypted with a closed or open network works fine.

    The frustrating thing is that I used to be able to connnect with encryption enabled until I updated the Apple Base station firmware to 5.1.1 ( i think it was 5.1.1, whatever it was 5.1.3 was released soon after and I updated to this). I can't remember what the old firmware version was, it was a number around 3.5 and was the one the Base Station shipped with. BTW if anyone has some earlier firmware and can email it to me I'd appreciate it.

    As far as I'm concerned the problem is with the apple firmware and/or wifi card drivers, but most likely with the apple firmware. I think this because I've tried connecting with a D-link 660 PCMCIA card which produces exactly the same results as connecting with the internal WiFi card.

    FYI I have tried all permutations of the following configurations (with both cards) : 40 bit and 128 bit encryption, "Use PC-friendly WEP Password" checked and unchecked, the password entered as WEP key on laptop and the Network Equivalent password entered as WEP key on laptop.

    Any ideas (or firmware :) ) would be appreciated but I think its actually up to apple to write some firmware. My main reason for posting this (apart from fishing for firmware :) ) is just to let anyone who is having the same problem know that I have exhausted all configuration options and to try something different or help me put pressure on apple.
  16. mannikin macrumors newbie

    Oct 30, 2003
    is there a solution for this?


    Did anyone figure out how to finally get this to work? I've tried the HEX entry of the passphrase, and messed with the advanced settings, but to no avail!

    I'm using XP, Airport and a Linksys WUSB12 USB adapter. I guess I am gonna have to email linksys tech support for some help in this matter. :(

  17. jonapete2001 macrumors regular

    Oct 20, 2003
    did you try to connect with the encryption turned off. I dont even use encryption. Also make sure that your true mobile card is not in Ad- Hock mode. This messed with my brothers airport statoin and my D-link wireless router. Darn Ad-Hock mode.
  18. mannikin macrumors newbie

    Oct 30, 2003
    Yeah, I was able to connect easily with no encryption. So, not sure what the deal is. Linksys replied back and said I have to use the HEX output of the passphrase to connect, which I think is totally lame! :(


  19. rueyeet macrumors 65816


    Jun 10, 2003
    Strangely enough, simply un-checking the "Create a closed network" in the AirPort Admin utility got it working for my housemate and I. We were then able to set up WEP encryption, using the hex key on her machine of course, and that works too. Go figure. I suspect that won't fix it for everyone.

    As to the WEP thing--yes, you have to use the hex key on the XP machine, because Windows doesn't use Apple's hash function that translates a user-friendly plaintext password to the hex thingy the 802.xx protocol requires. Apple is apparently the only company to think that people might like typing in a password they can remember and spell, instead of a string of gibberish.

    Although: one post at Apple's forums said that if you enclose the password in single quotes on the XP machine, and when you set it up on the Admin utility, but use it without the quotes elsewhere on your Mac, that you can use the text password. You had to use a 5-character password for 40-bit and a 13-character one for 128-bit, though. I haven't verified that--it would have been the next thing I tried. You might want to search Apple's boards for that post.
  20. Stuart macrumors newbie

    Oct 30, 2003

    Well actually, Orinoco based cards are probably the best 802.11b wifi cards on the market...the range is better than the even pricier Cisco Aironets. :rolleyes:
  21. GroundLoop macrumors 68000


    Mar 21, 2003
    AE and XP


    I am having the exact same problem as a few people above. I can see the newtwork but I cannot connect unless WEP is turned off. I absolutely need to have a WEP-enabled wireless network. I have tried entering the hex format given to me, and it is still a no go. here is my set-up:

    Dell Desktop with a Linksys WMP54G wireless Card (I use the windows Airport Extreme Admin Utility)

    Airport Extreme Base Station (5.1.3 firmware)

    With WEP disabled everything is fine. Can anybody give me a hand?

  22. halbarker macrumors newbie

    Nov 18, 2003
    I had the exact same problems while trying to connect my XP machine to my base station. I finally got the stupid thing to work by using XP's proprietary wireless network manager (i uninstalled my linksys wireless software). In the properties window I checked both the "Data Encryption [WEP Enabled]" box, and the "Network Authentication [Shared Mode]" box. I then entered the hex equivalent network key and it worked. I tried the same thing on my roomates XP dell with the same result. Hope this helps someone.
  23. cleo macrumors 65816


    Jan 21, 2002
    Tampa Bay Area, FL, USA
    I know this is an ancient thread, but I just wanted to thank everyone who was involved in it back in the day. Just today (after, like, 3 years of using WiFi) I realized I'd never set a password for the network, only a password to fiddle with the Airport itself. So I chose 128-bit encryption and all was well as I hooked the Macs up to the network, but for the life of me I couldn't get the Win XP laptop to connect... until I found this thread and learned about the hex passcode and where to find it.

    Ah, the power of "Search"! :D

Share This Page