Airport connection but no internet

Discussion in 'Macintosh Computers' started by billyb, Oct 4, 2004.

  1. billyb macrumors member

    Apr 26, 2003
    I'm having a problem with our Airport Dual Ethernet hardware. It's been connected to a variety of PCs and Macs for well over a year, with no problems. However, lately we have had to unplug its power/restart it several times a day. All the computers still connect just fine to the base station, but there's no internet available. Computers lose their IP addresses.

    Any thoughts? I'd really appreciate it.

    airport firmware v. 4.0.8.

    All computers have up-to-date drivers, for Panther, Jaguar, XP, w2000, etc.

    I looked through Apple's support and found something that fit the symptoms having to do with PPoE. Checked this, it's not the problem.

  2. makisushi macrumors 6502

    Jul 15, 2004
    Northern VA
    I have run into this type of problem before, it turns out that my airport was hit by a powersurge when my house was hit by lightning.
    I went through many hours of troubleshooting to no avail.

    No matter what the problem is, I would suggest that you go out and buy a new base station, the cost is greatly out weighed by the amount of time you are spending trying to fix it.
  3. hcuar macrumors 65816


    Jul 23, 2004
    1) Unplug the router and internet connection.
    2) Plug in the broadband modem.
    3) After the modem initializes, plug in the router (airport).
    4) If necessary, release and renew the IP addresses in the router setup.

    You're problem could be with your ISP as well. Consider calling them.
  4. billyb thread starter macrumors member

    Apr 26, 2003
    no modem here

    Thanks for the input, people. I'm actually in a big research building at a cable modem here, but I'll leave it unplugged a while and then try again. I doubt it was hit by a power surge since nothing else is damaged, though it could certainly be the case that the airport is more sensitive than other equipment. I'd just call the computer help people, but I can't since we pay by the IP address ... thus the AirPort is actually a covert operation.

    any other ideas before i have to buy a new one?
  5. Gee macrumors 65816

    Feb 27, 2004
    London, UK
    I had the same problem the other week, and I fixed it by resetting the basestation using that little button on the back, then setting it up again on a different channel. I think something nearby, like the neighbour's new microwave, was interfering with it.

    Worth a shot before you fork out for a new one - mines been fine ever since...
  6. switchedanhappy macrumors regular

    Nov 16, 2003
    ct usa
    have had similair probs with mine, try resetting it to the original factory settings (base station) i believe this is done in airport admin utility, since you're in a large research facility, I imagine you have ethernet comin out of the walls? if so, maybe test it in another room, as it may be a prob with your feed.
  7. rodcarr1 macrumors newbie

    Oct 5, 2004
    Airport connectivity not working?

    Are you still getting an IP address from your domain provider? Check the airport settings to see if you are still getting an IP address from the network.

    If you have an IP address, then check whether or not you are getting DNS services. You may need to enter your DNS addresses in your network setup. If it's not either of those things, then.....

    You might find that you need to get your netadmin to register your device as a "permitted" network device. Most netadmins are now implementing stronger security ("trusted device only" connections) for WiFi devices, which may mean that you need to get them to set it up for you.

    Give your network guys a call anyway - they may be able to fix it in a flash.

  8. Doraemon macrumors 6502

    Aug 31, 2001
    Europe (EU)
    Try following.

    Open the AirPort Admin Utility and select the tab for networking. Make sure the box for sharing IP addresses is unchecked.
  9. billyb thread starter macrumors member

    Apr 26, 2003

    Yesterday, as suggested above, I reset the AirPort and re-set it up to use a different channel. It hasn't frozen yet, but we'll see what happens. It'd been happening once every few days for a while, but yesterday it did it 3x in the same morning. thanks for the help...i'll keep posted on how it works. if it freezes again, i'll try the other suggestions!

  10. billyb thread starter macrumors member

    Apr 26, 2003
    don't distribute?

    In the APAU, there's a box for "Distribute IP addresses", and then two sub-boxes for "share a single IP address" or "share a range of IP addresses." I currently have the first box checked, in addition to the "single IP address" box.

    I'm not a networking guru by any standard, but I thought that in order to provide multiple computers an internet connection through a single ethernet jack (with one IP address), i thought this was what i had to do: have the AP distribute IP addresses. I haven't tried unchecking this...wouldn't this mean that we'd have to be paying for 9 IP addresses instead of 1?

    As a side note, I've been pretty impressed at how stable this connection has been given the range of machines that are on it (10.3, 10.2, XP, w2k, w98). yes, i know wireless is a standard, but still, it's not normal to see such a range playing together so nicely!

  11. billyb thread starter macrumors member

    Apr 26, 2003
    hard reset

    Kept crashing today, so I did a hard-reset and re-uploaded all the factory settings. in doing so, i noticed that it was working fine in DHCP mode (the base station itself, not the clients) whereas we had it configured manually before. i'll leave it like this and see if it works. thanks for the help, everyone.

  12. Doraemon macrumors 6502

    Aug 31, 2001
    Europe (EU)
    The thing is, that if you're inside a network or behind a router with DHCP, your AirPort station intervenes with the IP distribution by assigning a different IP than your network/router. In my case, the router assigned 192.168.1.x and AirPort assigned 10.0.1.x, hence it wasn't working. Ever since I unchecked all boxed in the networking tab, it works.

Share This Page