Airport connection horrible for laptop, fine for iPad / iPhone

Discussion in 'Mac Basics and Help' started by Ja Di ksw, Aug 11, 2011.

  1. Ja Di ksw, Aug 11, 2011
    Last edited: Aug 12, 2011

    Ja Di ksw macrumors 65816

    Ja Di ksw

    Joined:
    Apr 9, 2003
    #1
    I just got a new modem, it's wireless but the wireless is horrible on it, so it's hooked up to my airport express. Ever since I got it, the iPad and iPhone have gone on the Internet with no probem, but my MBP constantly struggles. It will work for 2 minutes, then not for 5 minutes. Then work for 6 minutes and not for 10 minutes. It's made the Internet on my MBP completely unusable. Does anyone have any tips for how to solve this? MBP is mid 2009 model, all OS's are the latest. iPhone 4 and iPad 1. AE is fairly new and the lit stays solid green. Thanks :).
     
  2. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #2
    Does the MBP only have trouble at home? Does wireless work normally when say at the coffee shop, library or school?
    If it does function normally outside the home then I would blame your new router. If not then I would take the MBP in to have it looked at.
    In all honesty return the router and buy an Airport Extreme. More money but way less headache.
     
  3. Ja Di ksw thread starter macrumors 65816

    Ja Di ksw

    Joined:
    Apr 9, 2003
    #3
    The MBP only has trouble with this new modem/router set-up. The old modem/router set-up (which included this airport express) worked perfectly fine. Switched up the modem, now only the iPhone and iPad work.
     
  4. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #4
    I have the opposite problem. My MBP can easily see even my neighbors WiFi, yet my iPhone and iPad doesn't see them.
     

Share This Page