Airport does not have an ip adress and cannot connect to the internet

Discussion in 'Mac Accessories' started by qwert1965, Apr 20, 2007.

  1. qwert1965 macrumors newbie

    Joined:
    Apr 20, 2007
    #1
    I have a problem with my macbookpro and connection to internet.
    1 week ago my computer as stopped to connect to internet.
    I was used connecting with my airport express, but at one point my macbook pro stopped receiving ip adress from interenet.
    the message on the network connection is Airport is connected to the network. Airport is does not have an IP address and Cannot connect to the internet
    I have try everything...:
    the Airport is working becouse all the others computers inside on my office are working well with airport.
    If I connect my computer with a cable I have the same problem.
    I have reset and restart Airport and computer.
    I have let my connection and computer disconnected and switched off for 24 our.
    I have verifyining that is not an hardware problem because I have installed a fresh OS on an external drive and when I boot from the external drive everything working well.
    The OS is on boot installation 10.4.9
    the machine is a Mac book pro 17 2.16 GHZ intel core duo with 2gb 667 Mhz.
    My problem is that on the old installation I have a lot of software installed and will be take a lot of time doing all the new installation. I wondering if there is a way to recover the situation.
    Any suggestion will be really appreciate...
    Thx a lot
     
  2. Winterfell macrumors regular

    Joined:
    Apr 3, 2007
    Location:
    Tulsa, Oklahoma
    #2
    And you've gone through your wireless router/switch's settings to make sure it hasn't started blocking your MBP? I can't tell if you have, so I thought I would ask. 90% of the time it has to do with settings on your router or switch's side that cause problems with computers trying to connect to it.

    Also, routers and switches maintain a table of ip addresses with which the computers connected to it have communicated, and when that table becomes full, they tend to slow down and sometimes behave irratically. A hard reboot of your router/switch (unplug it for a minute or two) can magically solve a lot of problems.
     
  3. qwert1965 thread starter macrumors newbie

    Joined:
    Apr 20, 2007
    #3
    NO I have not going, but I am sure that is a problem of my old installation of OS because my computer don't work on any other wireless or direct connection even on other place (other offices, other place where there are other wireless connection and where it was used to work). And if I boot from the external drive where I have installed a fresh os, it work normally.


     
  4. Richard Flynn macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #4
    Have you set your computer to automatically configure its IP address using DHCP? This is the default, but it may have been turned off somewhere along the way. Go to System Preferences > Network > AirPort > TCP/IP and make sure 'Configure IPv4' is set to 'Using DHCP'.
     
  5. qwert1965 thread starter macrumors newbie

    Joined:
    Apr 20, 2007
    #5
    yes is setted automatical
    I have inserted the snapshoot of the configurationa of my airport

     

    Attached Files:

  6. kermit4161 macrumors regular

    Joined:
    Dec 18, 2006
    #6
    I would also try to renew your DHCP lease to see if that will work (just press the button on the right side of the TCP/IP settings window) to request a new IP address from the DHCP server (or router/switch depending on how your network is setup).

    Then (if that doesn't work) I'd try resetting the router/switch as previously suggested. It is a quick thing to do (power it down for 30 secs... but tell everyone in the office you are doing it first in case someone is downloading a file... then power it back up). It is just one more step in eliminating the potential source of the problem. You might find that your laptop will connect right away after powering the router/switch back up.

    It sounds to me like it is a router/switch issue, not an OS issue. But, if all else fails, and your laptop can connect with a fresh install from an external drive, go ahead and do a new install (Archive and Install) of the system.


    Good luck
     
  7. qwert1965 thread starter macrumors newbie

    Joined:
    Apr 20, 2007
    #7
    well seem that archive and install is the only solution..:(
    There is a way to preserve al my installed software when I reinstall the OS?
    thanks
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    One more thing to try... this happened to me once with my iBook.

    System Prefs -> Network -> Locations -> New Location

    Then try configuring your network one more time from the new location. This happened to me in Panther, but nothing else seemed to explain the computer's stubborn refusal to get an IP address from the dept's Wifi network, and this, embarassingly, and for no clear reason, solved the problem.
     
  9. qwert1965 thread starter macrumors newbie

    Joined:
    Apr 20, 2007
    #9
    I have try to make a new location, but is the same the result.
    The strange is that he make the same connection problem with any kind of try to connect (modem, cable, gprs, wifi)
    It is a real mistery..:(
     
  10. nrecob macrumors newbie

    Joined:
    May 25, 2008
    Location:
    Atlanta (temporarily)
    #10
    mkrishnan, I can't thank you enough for your post! I was pulling out my hair trying to get my Mini back online after switching from one BellSouth Wireless Router to another--I jacked with it for hours and then finally noticed the "Airport does not have an IP address and cannot connect to the internet" message! I then had something to Google :) After googling this term, I got this page and started trying the different remedies...I tried two others first [one was very helpful as I now know how to renew my IP on a Mac because of it!] and then I tried your suggestion an BANG! I can get online! I owe you a beer--if you get down to Atlanta let me know :) THANKS AGAIN!

    Nik
     
  11. lortizo macrumors newbie

    Joined:
    Aug 15, 2009
    #11
    thanks!!!

    Awesome, it worked for me... Thank u
     
  12. rrmacfan macrumors newbie

    Joined:
    Aug 31, 2009
    #12
    I can't thank you enough, mkrishnan!! I was wrestling with this problem for half-a-day before I stumbled on to your post. Thanks again!!



     
  13. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #13
    Wow, I can't believe this problem still exists! :eek: You're welcome. :)
     
  14. care99 macrumors newbie

    Joined:
    Sep 9, 2009
    #14
    Wireless connection but no Internet

    I had this problem with an older iBook G4 I just bought - wireless was on and up but no internet connection said "You are not connected to the Internet" because there was no IP address. Searched forever online and finally learned that some older machines don't necessarily know to "automatically" configure their own IP addresses and need a little more direction. Finally found a solution at OpenDNS.com.

    Go to System Preferences > Network > AirPort > TCP/IP) type in
    208.67.222.222
    208.67.220.220
    in the DNS Servers box. Click apply changes. Be sure to use both addresses.

    For more oprions, go to https://www.opendns.com/start/ then click on "Computer" option. Select your OS, follow the directions. You can set up a free account to further tweak options - it activates via email.

    I had to restart my modem afterward (20 seconds off then back on) but after doing all these steps... Voila! I had an internet connection. :D

    *** Just a reminder to be careful when changing your setup!! Might want to write down what you started with before making changes. :eek:
     
  15. ashrafv macrumors newbie

    Joined:
    Oct 24, 2009
    #15
    Thanks!!!

    mkrishnan, let me echo what nrecob said - Your advice really helped me and I owe you a drink as well. So if you're ever in Dublin, Ireland let me know. Saturday night on bank holiday and your advice helped me back online!!!

    Thanks.
    Happy Halloween
     
  16. kve macrumors newbie

    Joined:
    Feb 25, 2010
    #16
    mkrishnan - many thanks for your suggestion - yes this problem still exists. I have a 2008 mbp running os 10.5.7 and this problem suddenly occurred!

    A question though - does this mean that you cannot use the Automatic function ever - as I did as you suggested - New Location....
     
  17. RedTemplar macrumors newbie

    Joined:
    Mar 31, 2010
    #17
    So, I was having this problem after switching routers and this worked wonderfully. I, sir/ma'am, owe you a beer. If you're ever in Detroit let me know. :)
     
  18. petesaul macrumors newbie

    Joined:
    Apr 12, 2010
    #18
    Airport Poblems



    Hi and thanks to all contributing around this subject. I had similar issues and was able to get back on the internet on 27" iMac by reseting the router.
     
  19. Healthy1 macrumors newbie

    Joined:
    Nov 21, 2010
    #19
    Thank you!

    Like others on this forum, my computer wasn't getting an IP address automatically and I tried everything to get one! Your idea was so simple yet it was the only one that worked for me. Thank you so much mkrishnan!

    Kindly,

    Russell

    PS I even joined this forum just to thank you!
     
  20. Tee65 macrumors newbie

    Joined:
    Nov 25, 2010
    #20
    I've tried everything and no net

    I've tried the suggested fixes bar reinstalling d
    software. MacBook still won't connect as it reverts to self assigned ip address when I renew dhcp lease.

    Tried new location, tried to reset modem
    & router. Even tried a different router & reset etc- still no go.

    The ip address just dropped out- 1 min it was connected, next it stopped.

    Any suggestions would be appreciated. (writing this on an iPhone that can connect!!)

    Thx T
     
  21. Tee65 macrumors newbie

    Joined:
    Nov 25, 2010
    #21
    Ok the problem mysteriously disappeared as it shown itself! I shut down the MacBook & left if off for over an hour. Turned it back on (being hopeful yet not thinking it would work), & after a few minutes & trying diagnostics, voila! it connected!

    Any thoughts? T
     
  22. *LTD* macrumors G4

    *LTD*

    Joined:
    Feb 5, 2009
    Location:
    Canada
    #22
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Mobile/8C148)

    Change your DNS server.

    If that doesn't work, look for a reset to factory defaults option.

    That is, if the problem persists.
     
  23. Turkeymil macrumors newbie

    Joined:
    Nov 25, 2010
    #23
    Same problem but with a twist....

    Hi, Can anyone help me resolve this???

    I have tried all the methods on here, but have still not had any joy in getting an ip address assigned automatically. I have a couple of imacs and a macbook. This problem only affects my macbook and only for the last few days.

    Macbook is 4 years ols running Mac OSX vers 10.5.8

    If I connect an ethernet cable from the router to the mac, no problemo, ip is assigned automatically. If I use airport I get the dreaded self assigned ip address when using the TCP/IP setting at DHCP. If i change the setting to DHCP with manual address and enter the address in IPv4 field, hey presto it works. So my question is why is the IP not picked up in the auto mode and can anyone help me fix it??
     
  24. Tee65 macrumors newbie

    Joined:
    Nov 25, 2010
    #24
    Thx *LTD* how do I change dns server, I'm not that tech savvy

    Thx T

     
  25. burnteous macrumors newbie

    Joined:
    Dec 2, 2010
    #25
    i have had this problem for the last 2 months. So initially i went into an Apple Store and saw a Genius about it. He showed be exactly what was suggested - create a new location. So yes, i could then immediately connect to the internet. After about a week or so, i had the issue about Airport does not have an ip address......... so i created a new location again and it worked again.... then again, i couldn't connect, and when this time i created a new location, it didn't work. So then i tried the OpenDNS.com program couple of days ago and that worked - changing the TCP/IP, DNS etc. And today i got home from work and its stopped working again, coming up with the same error of "Airport does not have an ip address......."

    The suggestions seems to work for a while, then fails, and then i try a new suggestion and works...then fails. I'm now out of options, no matter how many times i create a new location or tweek my DNS or renew my DHCP lease, i still get the same issue. My airport light is green and it's connected, but just can't seem to get an IP address.

    I've also tried rebooting router...etc.

    Any more suggestions guys?
     

Share This Page