Airport PC can't connect!

Discussion in 'Macintosh Computers' started by MattG, Jul 17, 2004.

  1. MattG macrumors 68040


    May 27, 2003
    Asheville, NC
    Hey my Airport Express last week. I've had no problems connecting to it with my Mac. My Dell laptop is another story...

    If I have *no* security enabled, the Dell connects just fine. However, once I enable WEP encryption, the Dell cannot connect, and I have verified several times that I have the encryption code typed in correctly. The Dell will not grab an IP. My Powerbook on the other hand is able to connect just fine when I enter the encryption code. Do I need to do something special to the Dell (or to the Airport Express) to make the Dell connect? Is there a certain way I need to type in the encryption code or something?!
  2. MikeLaRiviere macrumors regular

    May 25, 2004

    What kind of WEP encryption do you have enabled (what bit)?

    Try using 128 bit encryption.

    Mike LaRiviere
  3. zv470 macrumors 6502


    Jul 4, 2004
    If you've set it to WPA, use WEP128 instead. WPA isn't a standard, every vendor has their own implementation of it. Also try disabling security, then add your Dell to the list of computer allowed to access the AExpress (under: access control), then enable WEP. I don't know, that's just what I'd try. Good luck.
  4. WCat macrumors member


    That's good advice, but it sounds like you've already tried this. The problem is now how to get some security back on.

    By the way, WPA is a standard but not everybody has it if their gear is more than a year (or so) old. Not a problem if you have Apple, since they pushed it out in an Airport update quite a while ago, and all new gear ships with WPA working fine (including Airport Express). So, that's correct that it's not "standard" on lots of products, but it is now a required "standard" on new Wi-Fi certified products.

    The problem is probably due to how different manufacturers implement the user interface for wireless security, making it harder than it should be for most of us to set up cross-platform (and even same platform) security. Some require special checkboxes with terms that aren't the same meaning, like "Shared Secret". What's that?

    My advice is to try and get it running on 40-bit WEP, then walk away! It's good enough for home security unless you live near somebody with time on his hands and a desire to hack your WEP key. Not likely in my experience. It's really not much more secure than 128-bit WEP. I've hacked them both (purely in the interest of science ;)), and 128-bit takes just a bit more time.

    FWIW, my brother, another Mac fan, was given a Dell laptop at work about 4 months ago, and was told that's what he must use. He had a terrible time getting 128-bit WEP to work with his Airport Extreme at home. Finally got it going with some help from IT at work (who were fairly clueless), but he has a visible reaction every time somebody mentions Dells "True Mobile" WLAN software. He hates it. It's much harder than it should have to be.

    Try a simple 40-bit key. Try entering "HELLO" without the quotes--it's 5 ASCII characters--or try "1A2B3C4D5E" without the quotes. It's 10 HEX characters. Using uppercase avoids the problem of some WLAN software not recognizing HEX characters in lowercase. Stupid but true. Not a problem for Apple, but my SanDisk WLAN card for my IPAQ insists that HEX characters are uppercase only.

    If either of those keys work, then change a few characters to be more secure, and you should be done. Let me know what you find.


  5. MattG thread starter macrumors 68040


    May 27, 2003
    Asheville, NC
    Hey everyone--thanks for your responses.

    I didn't even try 128-bit encryption, and honestly I don't want to. Too long of a code to remember. I'm really not doing this to secure credit card purchases or anything like that. I'm just trying to keep neighbors off of my wireless connection :)

    I was using the 40-bit, and it worked fine with my Mac, just not the Dell. For now, I ended up making it a closed network so the SSID isn't broadcasted, that way at least nobody can connect to it without knowing the name of the network.
  6. WCat macrumors member


    Sorry for weird editing on my "2 for 1" responses!


    I was stuck in several phone calls while I totally re-edited my response. Looks strange! Again sorry for all the extra bits!

  7. blackpeter macrumors 6502a

    Aug 14, 2001
    Perhaps you can try putting a $ in front of the WEP key. First on the AX's key. If that doesn't work, try in front of the Dell's key.
  8. jtown macrumors 6502

    Jul 3, 2003
    This advice is probably on the right track. Seems like every wireless vendor has their own syntax for entering the code. Some want it in quotes if you're entering plaintext, some want the $ (or some other symbol) if you're entering the hexidecimal codes, some have a drop-down or button menu that lets you specify which type of code you're entering.

    Read the manual for the Dell and it should tell you how to specify which type of code is being entered. It sounds like the AX and mac are already set up right. It's just a matter of entering the code properly in the Dell.

Share This Page