Airport Express, unsupported USB printer, broadband

Discussion in 'Macintosh Computers' started by jeffhosier, Jun 13, 2004.

  1. jeffhosier macrumors newbie

    Jun 13, 2004
    I seem to have got my Airport Express configuration to work. It’s clear from the many Mac forums that this is a difficult problem, so here’s the way I managed to crack it.

    I have

    o A new iBook

    o A Samsung ML-1510 laser printer (not on Apple’s list of supported printers)

    o An Airport Extreme Base Station with its own dial-up modem

    I initially connected the Samsung and my dial-up ISP service directly to the iBook. When these were working, I connected them through the Airport. To make the printer work, I had to employ the trick mentioned in many places, of printing though the iBook USB and then plugging the printer into the Airport and turning it into a Rendezvous printer. This all worked fine for a couple of weeks.

    I then installed broadband using a router/modem (pre-configured by the broadband supplier) plugged into the WAN port of the Airport. The broadband self-installed instantly and worked fine, but the printer refused to work through the Airport. When I tried the trick of making it a Rendezvous printer, the Printer Set-up Utility just said that it couldn’t find the printer driver.

    I tried looking at the Airport Admin Utility and the Airport Set-up Assistant, but both claimed that they were unable to read the Airport Base station. Basically, this exhausted all the advice I could find.

    I then employed the following magic ritual which seemed to work.

    1 Disconnect base station completely

    2 Carry the base station to the kitchen table, give it a really hard stare, threaten it with a large hammer, and then wait for a few minutes to allow the adrenalin to disperse.

    3 Plug it all back together again (ADSL into Airport WAN port, printer into Airport USB port).

    4 This seemed to allow the Airport Admin Utility to work again.

    5 Open Airport Admin Utility.

    1 Click on Configure

    2 Click on Internet Connection. This showed that the Airport thought that was configured to connect via its own dial-up modem.

    3 Set Connect via to Ethernet

    4 Click on Update

    6 Use Printer Setup Utility to make the Samsung into a Rendezvous printer.

    Test it all. If it works, put sledgehammer back in toolbox, and bask in the warm glow of a job well done. If it doesn’t ...

    Two days on, all is well. If anyone tries this and it doesn’t work, it could be because you didn’t threaten it with a hammer. I regard this as the most crucial part of the whole process. There’s an old, and highly dubious English proverb “A dog, a wife, and a walnut tree, the more you beat them, the better they be” While I wouldn’t subscribe to that, I think a small threat of physical violence seems to work wonders with the Airport.

    Jeff Hosier, Bath, England
  2. Jo-Kun macrumors 6502a

    Dec 20, 2003
    You mean you airport extreme ;-) the express is the new one featuring airtunes...

    nice to have your airport extreme up and running with wireless printing...
  3. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    So does it work now or not? I'm confused. :confused:

    And side note...when its working for you, does your printer show up in the priinter blank of the airport admin utility's summary page? I have an Epson C84 (it *is* on the list) and it worked as soon as I plugged it in, but the printer box has always been blank, as if the airport itself didn't know the Epson was there....
  4. jeffhosier thread starter macrumors newbie

    Jun 13, 2004
    "Extreme" not "express"

    Jo-Kun: Quite right, it’s the Extreme. Apologies.

    Mkrishnan: Yes it does all work now.

    Now that I’ve got the Airport Admin Utility back, I can see the printer in the summary page.

    It’s interesting that your Airport acts “as if it doesn’t know the Epson is there” . When I eventually managed to look at the configuration of my device, it was convinced that I was using a dial up Internet connection, when it had been an ADSL for at least a week. But it was working fine on the ADSL.

    Try waving a hammer at yours to see if that brings it to its senses - it worked for mine.

    Jeff Hosier
  5. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Oh, mine *works* -- it just pretends not to see the printer. I don't want to intrude upon its fantasy land as long as I'm getting printing action. ;)

Share This Page