Airport Extreme Wont Accept Mr.Pc On WEP WPA or WPA2

Discussion in 'Mac Basics and Help' started by siz, Nov 23, 2008.

  1. siz macrumors newbie

    Oct 22, 2007
    Ignore this bit if your not bothered what and what doesn't connect:

    Well I have an iMac (New silver one that I bought on release date about a year and a bit old 4gb ram), a MacBook (White one about a year old 4gb ram) and a MacBook Pro (New silver one that I bought on release date just over a month old 4gb ram) and they all connect fine, my friend has a Dell Laptop (Inspiron 1500 Three years old 512mb ram) and that also connects fine, Plasystation 3 connects fine, iPhone connects fine, Printer connects fine, Laser Printer hasn't been set up yet but the chances are that will work.

    But then there's my other friend with his eMachines Laptop 256mb ram and it wont connect and it is complaining about security settings, why will it not connect, I do not want to remove my WPA2 key every time he comes round!, It will not even work on WPA and WEP. :mad:
  2. ravenvii macrumors 604


    Mar 17, 2004
    Melenkurion Skyweir
    I have a similar problem with my Time Capsule. MacBook Pro worked fine, iMac works fine, my girlfriend's Toshiba laptop works fine, but my old Compaq laptop with a NetGear PCMCIA wireless card just refuses to connect to the Time Capsule. It'd wait on the "communicating with the router" dialog (or something like that), then it disappears, and it rescans for networks, but never connects. It connects to the school network fine, though.

    I even turned off security completely, and same result.

    I'm clueless of what's up, but don't care to pursuit it because I'll soon be swapping that heavy laptop for a netbook.
  3. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Focus on relevant details, please... whether they connect to your router has nothing to do with how much RAM they have. What OS revision do they have?

    This is my experience with XP on my AEBS...

    For some reason, XP/SP2 could not handle making an initial connection with a hidden SSID network. If I turned my SSID broadcasting on, it could acquire the connection and then maintain it if I re-hid it, however. Also in SP2, Windows would only connect on WPA or WPA1/2 mixed.

    SP3 was able to connect to WPA2-only just fine.

    So first things, you might upgrade to SP3. Check and see if the wireless drivers are the latest available, also.
  4. mckyvlle macrumors 6502a

    Nov 21, 2007
    London, UK
    See also this Microsoft Knowledge Base article:

    Basically says install this to get Windows XP SP2 to connect to WPA2 Wifi.
  5. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Ahhh, good to know, for those users who cannot use SP3 for whatever reason. I remember several years ago (probably 2005, when I had already started using WPA2), someone brought an XP computer over to my house and I was completely bewildered by how much trouble it gave me to get it on my Airport.
  6. Scottsdale macrumors 601


    Sep 19, 2008
    I run Vista in Boot Camp fine.

    One thing is that I set it up to use the WPA2 and use just the same simple password as the key on Windows Vista as I do with the Mac. I thought would be different or wouldn't work as I recall having a similar problem to yours a few years ago.

    So, just now, I tried connecting an XP computer and it connected fine using the same password as the key. For some reason, I remember needing it to be 26 characters to work right before, but now worked with standard nine key password.

    May want to check into that. But in all honesty, it has been a while so may be forgetting something but you may want to try using 26 character password key and see if it works.

    One last thing I remember is having to tell the wireless network card to let Windows manage the card. Some wireless cards have their own software and you have to go into the card software and tell it to let Windows manage the card.

    Best wishes.
  7. i.shaun macrumors 6502a


    May 1, 2008
    If you want, you can disable security and see if that works.

    I don't use security on my network, but I do the following to protect it:

    -Change the SSID (Network Name) to something you'll remember.
    -Disable SSID Broadcast (it won't show up to anyone scanning for networks.)
    -Enable MAC Address filtering

    -enter the Wireless Address of each computer (it will look something like: 00:10:A1:9S:B3)
    -Make sure It's set to allow only the selected computers on the network

    Mac OS:
    -Sys PreferenceS>Network>select "Airport" and click "Configure"
    It is listed under "Airport ID"

    Windows OS:
    -Start>Run> type "CMD" hit enter. In the command prompt window, type "Ipconfig /all"

    -Write down the address you see under your "wireless adaptor"

    Airport Extreme:
    -Select "manually configure
    -select the "Access" Tab
    -Under MAC address control, select "Timed Access"
    -Edit "All Others" to NEVER have access
    -Click the "+" to add computer MAC addresses, and allow times access (or unlimited) to the network.

    This will ensure that no one can find your network, without knowing the SSID, and even if they do know it -- they cannot connect unless they have their computer's MAC address on the list.

    To access the network on your devices, manually enter the network name, and select "none" for security.
  8. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
    You know that offers zero protection, correct? You might as well not do anything at all.
  9. garybUK Guest


    Jun 3, 2002
    As stated this is about as useful as a chocolate teapot!
    MAC Addresses as VERY easy to spoof!!! by running some software that captures packets on your network, and even the most basic scanners will see through disabled SSID Broadcasting.
  10. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
    But at least the chocolate teapot is tasty. :D Never heard that one before.
  11. Wardotron macrumors member

    Oct 30, 2008
    I remember reading somewhere that WEP is no good in a mixed Mac/PC context as the character set is different. You could try setting to WPA and using a simple password using only letters and no numbers or special characters.
  12. *old-guy* macrumors regular

    Nov 22, 2007
    Blackburn in North West England
    I have no security on my home network either.
    Mostly because the last time I tried to do the WEP, WAP thing, I screwed up my PCs and couldn't connect anything to the web for 3 days.
    Another reason for not having any of this stuff is that my nearest neighbour is over a half mile away so anyone desperate enough to get a wireless connection for their laptop by driving 8 miles out of town, turn left at the busted tree and follow the track for 2 miles is welcome. Heck, just drive up to the shack and I'll make you a coffee, lol
  13. gjk2727 macrumors newbie

    Mar 17, 2008
    Dell 5160 or IBM Thinkpad won't connect to Airport Extreme

    I am new to MacForums. I read the comments but still don't know what to do to make pc laptops compatible for Airport Extreme. Can someone make it really simple?

    Before I switched from Airport Express Base Station (SNOW) everything worked. However router went bad and I had to buy a new one. I am using a 13 word password WPA2 - according to Apple technicians. They could not help with PC connections.

    I have:
    HP wireless printer - connected
    Imac G3 - connected
    Powerbook G4 - connected
    Dell Inspiron 5163 - can see network but can't access it
    IBM Thinkpad - can see network but can't access it
  14. HB80 macrumors newbie

    Feb 7, 2009
    gjk, how did you solve your problem? mine's the same

    I have the same problem connecting an XP machine to my airport extreme. The PC is an older Thinkpad with an Intel wireless card (2100 3B Mini PCI) running XP SP3. I updated the wireless card driver. I have the AE set up to use 802.11n (b/g compatible), channel 8, WPA/WPA2 Personal, 5.5 Mbps, MAC access not enabled. On Windows, I've tried various things (right now I disabled my wireless card and can't get it to enable again, but that's another story). Sometimes I see my network in the available wireless networks window, it says it's a WPA2 network, so I know I'm ok up to that point. I ask it to connect and it thinks and thinks and never does. Maybe I'm missing a Windows setting?
  15. gjk2727 macrumors newbie

    Mar 17, 2008
    Apple Genius Bar reset router

    I was stumped trying to connect PC's to network. I finally made an appointment with the Genius Bar and took the Airport Extreme, Powerbook and IBM laptop to the Apple Store. The problem was that neither laptop could not work with WPA - They are older computers.

    I'm not certain of everything the tech did. But I do know he reset the AE router. He deleted the password and made an unsecured connection. He set the router so it would not broadcast it's location. Each time someone enters the network, they have to add the name of the network on their first visit and then they don't have to reenter it again. He made sure the IBM and the Powerbook could read the Airport Extreme router.

    Now my HP printer, the Dell and the IBM all work on the network with the iMac and the Powerbook laptop - howbeit unsecured.

    I hope that helps.
  16. HB80 macrumors newbie

    Feb 7, 2009

    Thanks - That may be my problem too, since the laptop is older.
  17. gjk2727 macrumors newbie

    Mar 17, 2008
    Still Connected!

    Just an update.
    Dell Laptop, IBM laptop, Powerbook G4, iMac G3, HP Wireless are all still working with the network setup. One of my problems before was that I was able to get one of the PC's online and then the next time I tried to connect I couldn't. This is no longer a problem. I tried to solve this issue for a week. I literally lost days of productivity. I am so happy that the Apple Tech was able to solve this problem. HB80 - any luck yet?

Share This Page