Airport on imac G3 connecting to a linksys network

Discussion in 'Mac Apps and Mac App Store' started by karilind, Nov 3, 2003.

  1. karilind macrumors newbie

    Nov 3, 2003
    :confused: I have an imac g3 (OS 10.2.8) and I just bought a used airport card with an adapter and installed it into my imac. the mac recognizes the card and is able to make connections with my ibook (OS 9.2) that is sitting right next to it.

    However, it is not able to connect to the linksys base station that is downstairs. It doesn't see the station in internet connect. When I try to type in the name of the network it just says that an error occured while trying to connect.

    There is no security on the base station yet, and my ibook is able to connect fine to the base station. I thought it might be a bad card, so I swapped it with a different airport card and it does the same thing.

    I also tried installing the airport card in my other g3 (OS 9.2) and it does the same thing...can see computer to computer networks, but not the base station.

    I haven't tested either of the airport cards or the adapter on a system that works, so maybe I just was unlucky with two bad cards or a bad adapter.

    Does anyone have any ideas what is wrong or what to do?
  2. ftaok macrumors 603


    Jan 23, 2002
    East Coast
    Here's a suggestion.

    Can you swap out the Airport card from the iBook (card A) with the one in the iMac (card B)? If the result of this is that the iMac works and the iBook doesn't, then the problem is one of two things.

    1. Card B is defective.

    2. Card B is not on the router's access list.

    You say that there is no security settings on the router/base station. That doesn't necessarily mean that the acceess list isn't restricting certain cards.

    Before you start swapping cards, you should probably go to the router's settings and see if the access list is limited to certain devices.
  3. jonapete2001 macrumors regular

    Oct 20, 2003
    You might want to see if ad hoc mode is enables on this computer you are trying to set up. If ad hod mode is enables you will be able to conect to other computers but not to a router.
  4. karilind thread starter macrumors newbie

    Nov 3, 2003
    where do you disable ad hoc

    I am wary of messing around with opening up my ibook, but it might be easy to try turning the ad hoc functions off. Can you tell me how to do that?
  5. Peterf macrumors newbie

    Nov 9, 2003
    Well I guess all information is good information. I have precisely the same problem. I have a new eMac running OSX and with Airport factory fitted. My wireless modem is a DLink 604+. I don't have encryption running. I do have a strong signal. My Mac can see the SSID, but gives the same error message when I try to connect. It doesn't get a (192.x.x.x) IP address from the router's DHCP - I don't think it gets that far.

    I've trawled the forums, apples pages and Dlink and the only clue I've got so far is a suggestion that DLink and possibly the Mac need to be forced to run in 802.11b mode via a manual setting (rather than allowing auto selection of the Dlink+ mode and the Apple 802.11g mode). However it's as transparent as mud how to do that.

    So it may not be a problem with your equipment.

    I'm going to try apple support but I've a nasty feeling they'll blame DLink. And Dlink will blame.....

    Anyone got any ideas?

    PS and how do you turn ad hoc mode off with Airport?

Share This Page