"Album Artwork Not Modifiable" iTunes

Discussion in 'Mac Apps and Mac App Store' started by AdamZ, Nov 12, 2004.

  1. AdamZ macrumors regular

    Feb 15, 2004
    Well it seems others have had this problem, but I have been unable to find a solution upo searching. After ripping a number of CD's, both in AAC and Apple Lossless, I find later on that for some reason the "Artwork is not Modifiable". Now there are very few of these on Google and nothing from the Apple Site. Any help would be great, but as I am no newbie. So try and refrain from th obvious, reset permissions, restart, la la la.

    Attached Files:

    • mod.jpg
      File size:
      35.2 KB
    • not.jpg
      File size:
      13.4 KB
  2. dotnina macrumors 6502a

    Aug 19, 2004
    I've noticed this a lot lately, too. I wish I could remember the exact situations under which I've seen it.

    Try switching to another song, then coming back and playing it. See if it lets you "Drag Album Artwork Here." If that doesn't work, click on another playlist, then go back to the song and see if you can add artwork. I think one of these things or something like it worked for me.
  3. mj_1903 macrumors 6502a


    Feb 3, 2003
    Sydney, Australia
    While in the process of writing DupeTunes, I noticed that iTunes is very picky with regards to permissions and modifying the song file. See if changing permissions on it helps at all.
  4. Thomas Veil macrumors 68020

    Thomas Veil

    Feb 14, 2004
    OBJECTIVE reality
    Only time I've seen this is when the CD is still in the drive. Then, the computer assumes that's the file you're trying to modify, and the error message is its way of telling you, "Hey dummy, you can't add artwork to a commercial CD."
  5. mattwillis macrumors newbie

    Oct 4, 2005
    Needs an artist

    Seems to occur if you don't have an artist or the album is under "unknown artist" in the itunes folder. Put in an artist and you can then drag artwork in at album level...
  6. yenko macrumors 6502a

    Aug 29, 2005
    ...........that's what I was going to say! :D :D
  7. tomponce macrumors newbie

    Jul 17, 2002
    bad extension

    I had the same problem. I changed permissions to "read and write" for the audio file in the finder as well as all folders that contain that file that may have their permissions also set to "read only". Just make sure everything says "read and write" in the get info window.
  8. DigitalVagrant macrumors newbie

    Aug 7, 2006
    Check Import Encoder

    I realize this is an old thread, and by now hopefully you have found a solution. I was having the same problem ("Album Artwork Not Modifiable"). I did a Google search and stumbled upon this thread. Unfortunately, none of the suggestions above helped me. However upon closer inspection I realized that I had imported the album in WAV format.

    I am posting this just in case someone else has the same problem and happens to stumble upon this thread looking for an answer.

    Try checking your import encoder preferences.

    Edit > Preferences > Advanced > Importing > Import Using : MP3 Encoder

    (Mine was somehow changed to WAV Encoder, when I changed it back to MP3 Encoder I ceased having problems...however any album you have already uploaded as a WAV file will either have to be converted or you will have to re-upload)

    Hope that helps
  9. tsgsaz1 macrumors newbie

    Nov 7, 2006

    What can you do if you are unwilling to switch away from a high quality full recording format as wav. Is there a way to have artwork in iTunes with the music in a wav format? or What about Roxio products for the mac or as an iTunes client?
  10. ZXpower macrumors newbie

    Dec 21, 2006
    Riga, Latvia
    Seems like that the same problem with album artwork happens if your song is in VBR (Variable Bit Rate) format.
  11. killmoms macrumors 68040


    Jun 23, 2003
    Washington, DC
    Why not use Apple Lossless? No reason not to, and it can have artwork.
  12. rascalrg macrumors newbie

    Feb 14, 2007
    The issue seems to be file type or integrity

    Just had this problem after a batch conversion of shorten (SHN) > aiff > Apple Lossless (using xAct and iTunes itself, respectively). All but two of 33 files would accept album art, but I got the "Not Modifiable" message on two songs. The file types were correct, but the tracks wouldn't play. Turned out the aiff conversions were fine, but the Lossless conversions were corrupted. I deleted, re-imported the aiff's, re-converted to Lossless, and all is well. I might suggest that this indicator is a convenient way to see if any file types are corrupted without having to test every track, particularly for batch conversions.
  13. ebrunette macrumors newbie

    Mar 16, 2008
    MANY TRIALS, fixed in Vista

    I'm a long-time power user, and this problem really really pissed me off. In the end, this turned out to be partly a permissions issue and partly an ID3 tags issue for me.

    First, I prepared to call Apple support line:
    1. Updated to the latest version of Itunes
    3. Changed User Account Access Controls settings in Vista

    Then voila! I was able to drag and drop artwork.

    ID3 TAGS
    Check out wikipedia http://en.wikipedia.org/wiki/Id3http://en.wikipedia.org/wiki/Id3 for description of the evolution of ID3 tags. But I've been ripping my CD collection for years, and needed to update the ID3 tags to a version that supports integration of album artwork. Itunes will handle this for you: right click on selected tracks and select "Convert ID3 tags". Versions 2.0 and higher support album artwork. I selected V2.4 tags. It had to run overnight to convert my collection.

    Permissions in Vista
    Windows Vista has a feature called "Account Controls" that likes to interfere with MANY Apple apps. My login account is configured as an Administrator, but with Account Controls turned on, Vista still "protects" me from doing harm with a myriad of protection "Are you sure" popups. This can be turned off from the Start=>Settings=> Control Panel => Control Panel Home => User Accounts and Family Safety => User Accounts => "Turn User Account Control on or off". Open the form, uncheck the box and okay it.

    After fixing permissions, and updating ID3 tags, I was able to turn all of the file permissions for folders and tracks to R/W (uncheck "read only") and proceed with updating my library.
  14. OMGWTFBBQ macrumors member


    Oct 5, 2007
    still happening to me...

    I'm still having trouble with getting the artwork to recognize (in leopard with 7.6.1), I've changed the permissions back and forth both on the folder and on all the songs (they already were on read/write). I imported the songs from a cd in wav format... Any help with this would be greatly appreciated, thanks!
  15. duckduckmouse macrumors newbie

    Mar 20, 2008
    One possible solution

    OMGWTFBBQ - I was having the same problem. One work-around that worked for me was to convert one song to Apple Lossless (I chose one I didn't like as much as the others) and under "Get Info" linked the artwork .jpeg to that song, which serves as the album art for the rest of the album in the view I use most - Genre / Artist / Album with the tracks underneath. Hope this helps.
  16. billbobdole Guest

    GOT IT!! holy smokes was i stumped! all were itunes-made .m4a's, and got the old "not modifiable" & repaired permissions, etc failed.

    answer: NONE of the tracks had any info, besides the track name. Someone suggested it needed something in the artist field, but no deal. Then bam! it's the TRACK FIELD that needs something in it (the first one). I clicked out tracks 1-10 in that field (and no others), and now i can happily drag & drop artwork WITHOUT doing it in an info window! the "selected item" and "now playing" toggle still gets me tho..
  17. tobytothemax macrumors newbie

    Jun 9, 2008
    Alright, guys, I'm not sure if this was brought up before, but here's what worked for me: 1) Highlight all the songs whose covers aren't modifiable; 2) Right click and hit "Convert to AAC;" 3) Add artwork. Hope that helps.
  18. AliciaO macrumors newbie

    Jun 18, 2008
    I was recently experiencing this problem. It seems the cause was due (at least in part anyway) to the fact that the songs (wav files) I'd added were from a data disk... I burned the songs to a music cd (using Toast) and then popped that disk back in. iTunes picked it up, and I imported the songs as usual, and VOILA! I was allowed to modify the artwork.
    I doubt this will solve everyone's problems with this issue, but I hope it helps!

  19. mychemicalme macrumors newbie

    Jul 24, 2008

    :D Solved. I had this problem, then notice all the songs that had this problem were in wav format, so i simmply converted it into mp3, and da da
    Edit>Preferances>Advanced>Importing>Import Using=mp3 encoder>Ok>Choose Song>Advanced>Convert Selection To mp3.........DONE now add artwork
  20. Ken59 macrumors newbie

    Oct 20, 2008
    Hi DigitalVagrant. Just wanna say thanks so much. Your post really helped me. I'd spent ages looking for a solution to this problem and after reading your post I couldn't believe how simple the problem was. Thanks a mil.
  21. Gray-Wolf macrumors 68030


    Apr 19, 2008
    Pandora, Home Tree
    A variant of this issue, well sort of. Is with the new version of iTunes, the album artwork shows with the music, but the artwork screensaver can no longer find the artwork. Any help?

Share This Page